Subject: DateStyle config variable

From: Guillaume Lelarge <[email-masked]>
Date: Wed, 20 Dec 2006 20:59:51 +0100

Hi all,

I wondered if there was a reason for the mixed case capitalization of
the DateStyle setting ? all other settings are in lowercase. Even
DateStyle is in lowercase in the postgresql.conf file.

If there's none, here is a patch (CVS HEAD) to put it in lowercase.

Regards.

-- 
Guillaume.
<!-- http://abs.traduc.org/
     http://lfs.traduc.org/
     http://docs.postgresqlfr.org/ -->

---

From: Guillaume Lelarge <[email-masked]>
Date: Sat, 23 Dec 2006 10:41:54 +0100

> If there's none, here is a patch (CVS HEAD) to put it in lowercase.

Sorry, I forgot to add the patch... :-/

Regards.

-- 
Guillaume.
<!-- http://abs.traduc.org/
     http://lfs.traduc.org/
     http://docs.postgresqlfr.org/ -->
Index: src/sgml/config.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/config.sgml,v
retrieving revision 1.99
diff -u -3 -p -r1.99 config.sgml
--- src/sgml/config.sgml	12 Dec 2006 21:30:33 -0000	1.99
+++ src/sgml/config.sgml	20 Dec 2006 19:54:00 -0000
@@ -3491,10 +3491,10 @@ SELECT * FROM parent WHERE key = 2400;
 
      <variablelist>
 
-     <varlistentry id="guc-datestyle" xreflabel="DateStyle">
-      <term><varname>DateStyle</varname> (<type>string</type>)</term>
+     <varlistentry id="guc-datestyle" xreflabel="datestyle">
+      <term><varname>datestyle</varname> (<type>string</type>)</term>
       <indexterm>
-       <primary><varname>DateStyle</> configuration parameter</primary>
+       <primary><varname>datestyle</> configuration parameter</primary>
       </indexterm>
       <listitem>
        <para>
Index: src/sgml/datetime.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/datetime.sgml,v
retrieving revision 2.55
diff -u -3 -p -r2.55 datetime.sgml
--- src/sgml/datetime.sgml	17 Oct 2006 21:03:20 -0000	2.55
+++ src/sgml/datetime.sgml	20 Dec 2006 19:54:00 -0000
@@ -143,7 +143,7 @@
       <step>
        <para>
         Otherwise the date field ordering is assumed to follow the
-        <varname>DateStyle</> setting: mm-dd-yy, dd-mm-yy, or yy-mm-dd.
+        <varname>datestyle</> setting: mm-dd-yy, dd-mm-yy, or yy-mm-dd.
         Throw an error if a month or day field is found to be out of range.
        </para>
       </step>
Index: src/sgml/libpq.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/libpq.sgml,v
retrieving revision 1.221
diff -u -3 -p -r1.221 libpq.sgml
--- src/sgml/libpq.sgml	19 Dec 2006 01:53:36 -0000	1.221
+++ src/sgml/libpq.sgml	20 Dec 2006 19:54:02 -0000
@@ -885,7 +885,7 @@ Parameters reported as of the current re
 <literal>client_encoding</>,
 <literal>is_superuser</>,
 <literal>session_authorization</>,
-<literal>DateStyle</>,
+<literal>datestyle</>,
 <literal>TimeZone</>,
 <literal>integer_datetimes</>, and
 <literal>standard_conforming_strings</>.
Index: src/sgml/protocol.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/protocol.sgml,v
retrieving revision 1.66
diff -u -3 -p -r1.66 protocol.sgml
--- src/sgml/protocol.sgml	6 Sep 2006 20:40:47 -0000	1.66
+++ src/sgml/protocol.sgml	20 Dec 2006 19:54:02 -0000
@@ -1050,7 +1050,7 @@
     <literal>client_encoding</>,
     <literal>is_superuser</>,
     <literal>session_authorization</>,
-    <literal>DateStyle</>,
+    <literal>datestyle</>,
     <literal>TimeZone</>,
     <literal>integer_datetimes</>, and
     <literal>standard_conforming_strings</>.
Index: src/sgml/release.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/release.sgml,v
retrieving revision 1.488
diff -u -3 -p -r1.488 release.sgml
--- src/sgml/release.sgml	2 Dec 2006 00:46:46 -0000	1.488
+++ src/sgml/release.sgml	20 Dec 2006 19:54:04 -0000
@@ -1438,12 +1438,12 @@ links to the main documentation.
        <para>
         Make <link linkend="APP-INITDB"><application>initdb</></link>
         detect the operating system locale and set the default
-        <varname>DateStyle</> accordingly (Peter)
+        <varname>datestyle</> accordingly (Peter)
        </para>
 
        <para>
         This makes it more likely that the installed
-        <filename>postgresql.conf</> <varname>DateStyle</> value will
+        <filename>postgresql.conf</> <varname>datestyle</> value will
         be as desired.
        </para>
       </listitem>
Index: src/sgml/ref/copy.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/ref/copy.sgml,v
retrieving revision 1.77
diff -u -3 -p -r1.77 copy.sgml
--- src/sgml/ref/copy.sgml	18 Sep 2006 19:54:01 -0000	1.77
+++ src/sgml/ref/copy.sgml	20 Dec 2006 19:54:04 -0000
@@ -346,10 +346,10 @@ COPY <replaceable class="parameter">coun
 
    <para>
     <command>COPY</command> input and output is affected by
-    <varname>DateStyle</varname>. To ensure portability to other
+    <varname>datestyle</varname>. To ensure portability to other
     <productname>PostgreSQL</productname> installations that might use
-    non-default <varname>DateStyle</varname> settings,
-    <varname>DateStyle</varname> should be set to <literal>ISO</> before
+    non-default <varname>datestyle</varname> settings,
+    <varname>datestyle</varname> should be set to <literal>ISO</> before
     using <command>COPY TO</>.
    </para>
 
Index: src/sgml/ref/show.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/ref/show.sgml,v
retrieving revision 1.42
diff -u -3 -p -r1.42 show.sgml
--- src/sgml/ref/show.sgml	16 Sep 2006 00:30:20 -0000	1.42
+++ src/sgml/ref/show.sgml	20 Dec 2006 19:54:04 -0000
@@ -138,11 +138,11 @@ SHOW ALL
   <title>Examples</title>
 
   <para>
-   Show the current setting of the parameter <varname>DateStyle</varname>:
+   Show the current setting of the parameter <varname>datestyle</varname>:
 
 <programlisting>
-SHOW DateStyle;
- DateStyle
+SHOW datestyle;
+ datestyle
 -----------
  ISO, MDY
 (1 row)

---

From: Tom Lane <[email-masked]>
Date: Sat, 23 Dec 2006 11:06:15 -0500

>> DateStyle is in lowercase in the postgresql.conf file.

DateStyle and TimeZone have both historically been spelled like that,
and are delivered to client code in that form (not only in SHOW but
in the lower-level ParameterStatus message).  I think the odds of
breaking client-side code are very high if we change it.

			regards, tom lane