Subject: Undocumented trick in SELECT?

From: Виктор Вислобоков <[email-masked]>
Date: Sun, 4 Apr 2010 17:01:28 +0400

I'm sorry, but I have not found such construction into documentation:

SELECT tablename FROM tablename;

http://www.postgresql.org/docs/8.4/static/queries-overview.html
say:

[WITH with_queries] SELECT select_list FROM table_expression
[sort_specification]

http://www.postgresql.org/docs/8.4/static/queries-select-lists.html
say:
"The select list determines which columns of the intermediate table are
actually output."

But, table name is not a column.

Reproduce:

tmp=# create table tmp(id SERIAL, name VARCHAR(10));
NOTICE:  CREATE TABLE will create implicit sequence "tmp_id_seq" for serial
column "tmp.id"
CREATE TABLE
tmp=# insert into tmp (name) values('John');
INSERT 0 1
tmp=# insert into tmp (name) values('Pol');
INSERT 0 1
tmp=# insert into tmp (name) values('Martin');
INSERT 0 1
tmp=# select tmp from tmp;
    tmp
------------
 (1,John)
 (2,Pol)
 (3,Martin)
(3 rows)

What is this? Is  this undocumented or am I bad looked in the documentation?

With best wishes,
Victor Vislobokov
St.Peterburg. Russia

---

From: Tom Lane <[email-masked]>
Date: Sun, 04 Apr 2010 12:26:17 -0400

> SELECT tablename FROM tablename;

It's a whole-row variable.  These aren't terribly well documented but you
can find descriptions of them in places.  It's not standard SQL --- I
think we inherited it from PostQUEL and kept it because functions on
composite types don't work very well without composite variables.

			regards, tom lane