Subject: log_connections and log_disconnections

From: Fujii Masao <[email-masked]>
Date: Fri, 27 May 2011 20:51:39 +0900

Hi,

The GucContext of log_connections and log_disconnections is PGC_BACKEND.
So, in the document, we should use the following expressions

        This parameter cannot be changed after session start.

instead of

        This parameter can only be set in the postgresql.conf file or
on the server command line.

for them? The former is used also for other PGC_BACKEND
parameters (e.g., post_auth_delay). I attached the patch.

Regards,

-- 
Fujii Masao
NIPPON TELEGRAPH AND TELEPHONE CORPORATION
NTT Open Source Software Center
*** a/doc/src/sgml/config.sgml
--- b/doc/src/sgml/config.sgml
***************
*** 3527,3534 **** local0.*    /var/log/postgresql
         <para>
          Causes each attempted connection to the server to be logged,
          as well as successful completion of client authentication.
!         This parameter can only be set in the <filename>postgresql.conf</>
!         file or on the server command line.  The default is off.
         </para>
  
         <note>
--- 3527,3534 ----
         <para>
          Causes each attempted connection to the server to be logged,
          as well as successful completion of client authentication.
!         This parameter cannot be changed after session start.
!         The default is off.
         </para>
  
         <note>
***************
*** 3553,3560 **** local0.*    /var/log/postgresql
          <varname>log_connections</varname> but at session termination,
          and includes the duration of the session.  This is off by
          default.
!         This parameter can only be set in the <filename>postgresql.conf</>
!         file or on the server command line.
         </para>
        </listitem>
       </varlistentry>
--- 3553,3559 ----
          <varname>log_connections</varname> but at session termination,
          and includes the duration of the session.  This is off by
          default.
!         This parameter cannot be changed after session start.
         </para>
        </listitem>
       </varlistentry>

---

From: Peter Eisentraut <[email-masked]>
Date: Sun, 29 May 2011 22:00:38 +0300

> parameters (e.g., post_auth_delay). I attached the patch.

Committed.