Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1qpqa1-007G7D-Lu for pgsql-docs@arkaria.postgresql.org; Mon, 09 Oct 2023 13:45:53 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.94.2) (envelope-from ) id 1qpqZz-00E0Lq-JJ for pgsql-docs@arkaria.postgresql.org; Mon, 09 Oct 2023 13:45:52 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1qpqZz-00E0Li-BF for pgsql-docs@lists.postgresql.org; Mon, 09 Oct 2023 13:45:52 +0000 Received: from sss.pgh.pa.us ([68.162.161.243]) by makus.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1qpqZx-000nGP-OT for pgsql-docs@lists.postgresql.org; Mon, 09 Oct 2023 13:45:51 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.15.2/8.15.2) with ESMTP id 399DjkrE133679; Mon, 9 Oct 2023 09:45:46 -0400 From: Tom Lane To: Daniel Gustafsson cc: "David G. Johnston" , Kirk Parker , pgsql-docs@lists.postgresql.org Subject: Re: Typo in PL/pgSQL trigger Example 43.4? In-reply-to: References: <3179621.1696710121@sss.pgh.pa.us> Comments: In-reply-to Daniel Gustafsson message dated "Mon, 09 Oct 2023 10:53:07 +0200" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <133677.1696859146.1@sss.pgh.pa.us> Content-Transfer-Encoding: quoted-printable Date: Mon, 09 Oct 2023 09:45:46 -0400 Message-ID: <133678.1696859146@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk Daniel Gustafsson writes: >> On 7 Oct 2023, at 22:22, Tom Lane wrote: >> Yeah, either way has the same result. However, I wonder if we should >> change this example to use current_user for clarity. It does look >> more like it's intended to be a variable or column reference than >> a built-in function. > Agreed, and "user" is a hard search term to use for discovering what it = is. +1 > for changing to current_user. OK, I'll take care of this later today. regards, tom lane