Subject: doc page: ALTER VIEW

From: "Sahagian, David" <[email-masked]>
Date: Wed, 2 Jan 2013 11:58:24 -0500

On the doc page for ALTER VIEW . . .

In the discussion about SET/DROP DEFAULT,
I am thinking that [instead-of insert trigger] should be mentioned in addition to [ON INSERT rule].

"A default value associated with a view column is inserted into INSERT statements on the view before the view's ON INSERT rule is applied, . . ."

Thanks,
-dvs-

---

From: Peter Eisentraut <[email-masked]>
Date: Sat, 09 Feb 2013 08:31:55 -0500

> "A default value associated with a view column is inserted into INSERT statements on the view before the view's ON INSERT rule is applied, . . ."

This paragraph was rewritten as part of the updatable views patch, and
it appears to now say what you wanted.

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Tom Lane <[email-masked]>
Date: Sat, 09 Feb 2013 11:44:50 -0500

> it appears to now say what you wanted.

Looking at this page, it occurred to me that there really ought to be
an explicit example of using SET DEFAULT.  So I added one.

			regards, tom lane