Subject: Fwd: PostgreSQL 7.4 documentation packaging

From: Josh Berkus <[email-masked]>
Date: Mon, 19 Apr 2004 15:18:19 -0700

Folks,

Just got this request from Mark Recht, who maintains an RPM package library at 
www.pkgsrc.org.    It seems that we don't have an option for compile for our 
docs which is standard with other Linux tools.    How difficult would this be 
to add?    It would help Mark keep our packages updated.

-- 
-Josh Berkus
 Aglio Database Solutions
 San Francisco
700
Date: Tue, 20 Apr 2004 00:07:55 +0200
From: Marc Recht <[email-masked]>
To: [email-masked]
Subject: PostgreSQL 7.4 documentation

--==========C7328C07F960314EC872==========
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline
Subject: 

Like discussed on IRC just a few seconds ago ;-)

From a packaging point of view tt'd be nice if PostgreSQL would have an=20
extra
--with-htmldir
option. By default pkgsrc seperates "normal" documentation and HTML=20
documentation. The former goes to ${PREFIX}/share/doc/<pkg> the latter to=20
${PREFIX}/share/doc/html/<pkg>. Currently, with only --docdir, the sources=20
have to be patched to archieve that.

Cheers,
Marc

--==========C7328C07F960314EC872==========
Content-Type: application/pgp-signature
Content-Transfer-Encoding: 7bit
Subject: 

--==========C7328C07F960314EC872==========--

---

From: Peter Eisentraut <[email-masked]>
Date: Wed, 21 Apr 2004 14:36:59 +0200

Am Dienstag, 20. April 2004 00:18 schrieb Josh Berkus:
> Just got this request from Mark Recht, who maintains an RPM package library
> at www.pkgsrc.org.    It seems that we don't have an option for compile for
> our docs which is standard with other Linux tools.    How difficult would
> this be to add?    It would help Mark keep our packages updated.

pkgsrc is a NetBSD package library, not an RPM library.  We do have a target 
to "compile" the documentation, which is how the documentation is built in 
the first place.  I don't know what "standard" there is about that.

---

From: Tom Lane <[email-masked]>
Date: Wed, 21 Apr 2004 14:34:13 -0400

Peter Eisentraut <[email-masked]> writes:
>> at www.pkgsrc.org.

> the first place.  I don't know what "standard" there is about that.

I think what he was actually asking for was to provide a relatively
simple way (like a configure option) of installing the HTML docs into
a different directory from the plaintext docs.  It didn't sound like an
unreasonable request ...

			regards, tom lane

---

From: Peter Eisentraut <[email-masked]>
Date: Wed, 21 Apr 2004 21:04:51 +0200

Tom Lane wrote:
> a different directory from the plaintext docs.  It didn't sound like
> an unreasonable request ...

You can use --with-docdir.  There are no other docs besides the HTML 
ones, so this allows you to place the HTML docs anywhere you like.