Subject: FW: [webmaster] Possible error in documentation for EXTRACT

From: Mark Clark <[email-masked]>
Date: Wed, 6 Apr 2016 17:05:40 +0000

TWIMC,
           In the documentation for EXTRACT<http://www.postgresql.org/docs/9.5/interactive/functions-datetime.html#FUNCTIONS-DATETIME-EXTRACT>, the example for “century" is as follows:

SELECT EXTRACT(CENTURY FROM TIMESTAMP '2000-12-16 12:21:13');
Result: 20
SELECT EXTRACT(CENTURY FROM TIMESTAMP '2001-02-16 20:38:40');
Result: 21

I believe the result for the second SELECT is incorrect. I believe it should be:

SELECT EXTRACT(CENTURY FROM TIMESTAMP '2001-02-16 20:38:40');
Result: 20

Alternatively, you could change the example to:

SELECT EXTRACT(CENTURY FROM TIMESTAMP '2100-02-16 20:38:40');
Result: 21

If I have missed some point about how this should work, then please ignore this e-mail.

Thanks,
Mark Clark
[email-masked]

---

From: Reid Thompson <[email-masked]>
Date: Wed, 6 Apr 2016 20:06:26 +0000

On Wed, 2016-04-06 at 17:05 +0000, Mark Clark wrote:
> 
> TWIMC,
>            In the documentation for EXTRACT, the example for “century" is as
> follows:

$ psql test
Timing is on.
psql (9.5.2)
Type "help" for help.

test=# SELECT EXTRACT(CENTURY FROM TIMESTAMP '2001-02-16 20:38:40');
 date_part 
-----------
        21
(1 row)

Time: 1.336 ms
test=# 

the 21st century began on 2001-01-01.
-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs