Subject: Default user 'postgres' not mentioned in the documentation?

From: PG Doc comments form <[email-masked]>
Date: Sun, 22 Dec 2019 14:37:03 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/12/postgres-user.html
Description:

Hi

I'm a newbie and may be asking stupid questions... but 
shouldn't it be mentioned in the official documentation on this page
https://www.postgresql.org/docs/12/postgres-user.html
that postgresql upon installation automatically creates a system-user that's
called 'postgres' ?

I thought it was odd that I had to find that information on other websites

(e.g. here:
https://medium.com/coding-blocks/creating-user-database-and-adding-access-on-postgresql-8bfcd2f4a91e)

Now I'm still confused, if the docs want to tell me I should create yet
another user for safety reasons or if that's not necessary...

Thanks for clarification, any comment is valuable to me
Best regards

---

From: Tom Lane <[email-masked]>
Date: Sun, 22 Dec 2019 11:17:08 -0500

> that postgresql upon installation automatically creates a system-user that's

No, because Postgres as distributed by us does no such thing.

Many vendors' packagings of Postgres create such a user (as is also
often true of their packagings of other service-type software).  But
it's up to the package's documentation to tell you about that.  Look
for a README-type file installed by the package.

			regards, tom lane