Subject: Wrong 'Special local variables PG_' prefix in 'Trigger procedures' section

From: PG Doc comments form <[email-masked]>
Date: Tue, 20 Mar 2018 12:19:04 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/10/static/plpgsql-trigger.html
Description:

The documentation (10 and 9.6) contains a typo when mentioning 'Special
local variables PG_something'. Instead it should be 'Special local variables
TG_something' as it is for trigger local variables.

Examples just below all start with TG_ so it should be obvious.

---

From: Tom Lane <[email-masked]>
Date: Tue, 20 Mar 2018 11:16:08 -0400

> TG_something' as it is for trigger local variables.

Ugh, yeah, that's a thinko isn't it.  Will fix, thanks for noticing!

			regards, tom lane