Subject: Missing documentation for pg_role column

From: Bruce Momjian <[email-masked]>
Date: Wed, 4 May 2011 14:37:17 -0400 (EDT)

I noticed that pg_role.rolconfig isn't documented in catalog.sgml.  Is
this an oversight?  Are other things missing?

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + It's impossible for everything to be true. +

---

From: Tom Lane <[email-masked]>
Date: Wed, 04 May 2011 16:21:54 -0400

> this an oversight?  Are other things missing?

ITYM pg_roles?  Yeah, that column seems to be missing.  And the claim
that it's "simply a view of pg_authid" is obsolete too, precisely
because this column isn't from there anymore.  That ought to be
rephrased or removed entirely.

			regards, tom lane