Subject: Notes about COMMIT on an aborted transaction will automatically cause a rollback

From: PG Doc comments form <[email-masked]>
Date: Thu, 26 Feb 2026 11:43:04 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/18/sql-commit.html
Description:

Probably it's good idea to add note about COMMIT on an aborted transaction
will automatically cause a rollback, because i can't find this sentence in
the documentation for now.

---

From: "David G. Johnston" <[email-masked]>
Date: Thu, 26 Feb 2026 07:19:25 -0700

> the documentation for now.

There is a patch waiting for a committer.

https://commitfest.postgresql.org/patch/5546/

David J.