Subject: Error in 18.4 release notes

From: PG Doc comments form <[email-masked]>
Date: Fri, 15 May 2026 09:15:36 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/18/release-18-4.html
Description:

The 18.4 release notes say this: "Use timing-safe string comparisons in
authentication code (Michael Paquier) Use timingsafe_bcmp() instead of
memcpy() or strcmp() when checking passwords, ..."

I think that should be memcmp() instead of memcpy().

---

From: Tom Lane <[email-masked]>
Date: Fri, 15 May 2026 18:13:27 -0400

> I think that should be memcmp() instead of memcpy().

Sigh, you're right --- that's my thinko.  Will fix in git for posterity's
sake, though the notes are already out and probably no-one will care
anymore by the time of the next release.

			regards, tom lane