Subject: looking for documentation about the optimizer

From: "Alice Lottini" <[email-masked]>
Date: Tue, 22 Oct 2002 16:15:57 +0200

Hi,
I'm a student in Informatics Engineering and I'm working at my thesis, for which I have to integrate one or more primitives in PostgreSQL in order to support data mining algorithms; this task firstly requires a deep analysis on the PostgreSQL optimizer (the way it works and its source code).
Does anybody know where I can find some documentation about the PostgreSQL optimizer?
I've read some old messages (1997) about an "Implementation Guide" but the related link seems to be obsolete ("page not found")...
Any suggestion is welcome!
thanks in advance, alice

---

From: Tom Lane <[email-masked]>
Date: Tue, 22 Oct 2002 10:49:08 -0400

"Alice Lottini" <[email-masked]> writes:
> Does anybody know where I can find some documentation about the PostgreSQL =
> optimizer?

Aside from the general info in the Developer's Guide, there are README
files in the source tree that you should look at:
	src/backend/optimizer/README
	src/backend/optimizer/plan/README
After that, start reading the code ...

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 22 Oct 2002 13:06:14 -0400 (EDT)

> After that, start reading the code ...

And some papers on the web site in the Developer's Corner.

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073