Subject: functions-matching correct?

From: Joe Conway <[email-masked]>
Date: Mon, 19 Aug 2002 13:42:35 -0700

7.2.1 docs:
http://www.postgresql.org/idocs/index.php?functions-matching.html#FUNCTIONS-LIKE

" It's also possible to select no escape character by writing ESCAPE ''. 
In this case there is no way to turn off the special meaning of 
underscore and percent signs in the pattern."

7.3 development docs:
http://developer.postgresql.org/docs/postgres/functions-matching.html#FUNCTIONS-LIKE

" It's also possible to select no escape character by writing ESCAPE ''. 
This effectively disables the escape mechanism and turns off the special 
meaning of underscore and percent signs in the pattern."

I think the former is still correct, isn't it?

Joe

---

From: Tom Lane <[email-masked]>
Date: Mon, 19 Aug 2002 17:21:39 -0400

> I think the former is still correct, isn't it?

Yes, as is easily proven by experiment:

regression=# select 'foo' LIKE 'f%';
 ?column?
----------
 t
(1 row)

regression=# select 'foo' LIKE 'f%' escape '';
 ?column?
----------
 t
(1 row)

Who put that change in?

			regards, tom lane

---

From: Joe Conway <[email-masked]>
Date: Tue, 20 Aug 2002 23:12:54 -0700

> regression=# select 'foo' LIKE 'f%';

Here's a small doc patch to fix this issue. Please apply.

Thanks,

Joe

Index: doc/src/sgml/func.sgml
===================================================================
RCS file: /opt/src/cvs/pgsql-server/doc/src/sgml/func.sgml,v
retrieving revision 1.114
diff -c -r1.114 func.sgml
*** doc/src/sgml/func.sgml	21 Aug 2002 05:25:49 -0000	1.114
--- doc/src/sgml/func.sgml	21 Aug 2002 05:42:49 -0000
***************
*** 2238,2246 ****
     <para>
      It's also possible to select no escape character by writing
      <literal>ESCAPE ''</literal>.  This effectively disables the
!      escape mechanism and
!      turns off the special meaning of underscore and percent signs in
!     the pattern.
     </para>
  
     <para>
--- 2238,2245 ----
     <para>
      It's also possible to select no escape character by writing
      <literal>ESCAPE ''</literal>.  This effectively disables the
!     escape mechanism, which makes it impossible to turn off the
!     special meaning of underscore and percent signs in the pattern.
     </para>
  
     <para>

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 21 Aug 2002 12:09:19 -0400 (EDT)

Your patch has been added to the PostgreSQL unapplied patches list at:

	http://candle.pha.pa.us/cgi-bin/pgpatches

I will try to apply it within the next 48 hours.

---------------------------------------------------------------------------

> 
> ---------------------------(end of broadcast)---------------------------
> TIP 2: you can get off all lists at once with the unregister command
>     (send "unregister YourEmailAddressHere" to [email-masked])

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 22 Aug 2002 00:56:53 -0400 (EDT)

Patch applied.  Thanks.