Subject: PostgreSQL 7.2 Documentation

From: "Mathias Zajaczkowski" <[email-masked]>
Date: Mon, 2 Sep 2002 16:43:20 +0200

3.3. Foreign Keys

[..]
CREATE TABLE cities (
	name		varchar(80) primary key,
	location	point
);

CREATE TABLE weather (
	city		varchar(80) references weather,
	temp_lo		int,
	temp_hi		int,
	prcp		real,
	date		date
);

Table weather refernces table cities and not itself.
Best regards

Mathias Zajaczkowski,
UBIK S.A.
Av. Cortot 7d,
1260, Nyon, Switzerland
Tel : +41 22 362 04 60
Fax: +41 22 362 04 61
mailto:[email-masked]
http://www.ubik.ch

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 3 Sep 2002 13:52:12 -0400 (EDT)

Yes, this is fixed in 7.3, due out in a few months.

---------------------------------------------------------------------------

Mathias Zajaczkowski wrote:
> ?

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073