Subject: VERY SMALL DOC BUG: http://www.postgresql.org/idocs/index.php?sql-createtable.html

From: Janning Vygen <[email-masked]>
Date: Tue, 3 Sep 2002 17:12:59 +0200

Hi,

In document 
http://www.postgresql.org/idocs/index.php?sql-createtable.html

it says (Parameters, third section):

NOT NULL
     The column is not allowed to contain NULL values. This is  
equivalent to the column constraint CHECK (column NOT NULL). 

At the end it must say:

CHECK (column IS NOT NULL).
              ^^

thanks for maintaining/developing postgresql!! Great database!

kind regards,
janning

-- 
PLANWERK 6 /websolutions
Herzogstraße 86
40215 Düsseldorf

fon 0211-6015919
fax 0211-6015917
http://www.planwerk6.de

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 3 Sep 2002 14:59:34 -0400 (EDT)

Looks like this is already fixed in 7.3, due out in a few months:

    A not-null constraint is always written as a column constraint.  A
    not-null constraint is equivalent to creating a check constraint
    <literal>CHECK (<replaceable>column_name</replaceable> IS NOT
    NULL)</literal>, but in <productname>PostgreSQL</productname>

---------------------------------------------------------------------------

Janning Vygen wrote:
> Herzogstra?e 86
> 40215 D?sseldorf
> ---------------------------(end of broadcast)---------------------------
> TIP 4: Don't 'kill -9' the postmaster
> 

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073