Subject: Extra indexing, multibyte correction

From: Oliver Elphick <[email-masked]>
Date: 03 Nov 2002 00:27:51 +0000

This patch adds a couple of extra index entries and removes some
out-of-date text about multibyte encoding (which is now always
included).

-- 
Oliver Elphick                                [email-masked]
Isle of Wight, UK                            
http://www.lfix.co.uk/oliver
GPG: 1024D/3E1D0C1C: CA12 09E0 E8D5 8870 5839  932A 614D 4C34 3E1D 0C1C
                 ========================================
     "Lo, children are an heritage of the LORD; and the  
      fruit of the womb is his reward."        Psalms 127:3 
Index: doc/src/sgml/extend.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql-server/doc/src/sgml/extend.sgml,v
retrieving revision 1.17
diff -u -r1.17 extend.sgml
--- doc/src/sgml/extend.sgml	2002/09/21 18:32:53	1.17
+++ doc/src/sgml/extend.sgml	2002/11/03 00:20:16
@@ -5,6 +5,10 @@
  <chapter id="extend">
   <title>Extending <acronym>SQL</acronym>: An Overview</title>
 
+   <indexterm zone="extend">
+    <primary>extending SQL</primary>
+   </indexterm>
+
   <para>
    In  the  sections  that follow, we will discuss how you
    can extend the <productname>PostgreSQL</productname> 
@@ -75,6 +79,15 @@
   <sect1 id="type-system">
    <title>The <productname>PostgreSQL</productname> Type System</title>
 
+   <indexterm zone="type-system">
+    <primary>extending SQL</primary>
+    <secondary>types</secondary>
+   </indexterm>
+
+   <indexterm zone="type-system">
+    <primary>data types</primary>
+   </indexterm>
+
    <para>
     The <productname>PostgreSQL</productname> type system
     can be broken down in several ways.
@@ -108,6 +121,10 @@
 
   <sect1 id="pg-system-catalogs">
    <title>About the <productname>PostgreSQL</productname> System Catalogs</title>
+
+   <indexterm zone="pg-system-catalogs">
+    <primary>catalogs</primary>
+   </indexterm>
 
    <para>
     Having  introduced the basic extensibility concepts, we
Index: doc/src/sgml/runtime.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql-server/doc/src/sgml/runtime.sgml,v
retrieving revision 1.146
diff -u -r1.146 runtime.sgml
--- doc/src/sgml/runtime.sgml	2002/10/20 01:43:32	1.146
+++ doc/src/sgml/runtime.sgml	2002/11/03 00:20:24
@@ -1311,11 +1311,6 @@
         Sets the client-side encoding for multibyte character sets.
 	The default is to use the database encoding.
        </para>
-       <para>
-        This option is only available if
-        <productname>PostgreSQL</productname> was built with multibyte
-        support.
-      </para>
       </listitem>
      </varlistentry>

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 2 Nov 2002 20:31:18 -0500 (EST)

Patch applied.  Thanks.

---------------------------------------------------------------------------

> out-of-date text about multibyte encoding (which is now always

[ text/x-patch is unsupported, treating like TEXT/PLAIN ]

> 
> ---------------------------(end of broadcast)---------------------------
> TIP 3: if posting/reading through Usenet, please send an appropriate
> subscribe-nomail command to [email-masked] so that your
> message can get through to the mailing list cleanly

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073