Subject: Documentation bug report for LIMIT

From: Jean-Christian Imbeault <[email-masked]>
Date: Wed, 06 Nov 2002 13:39:55 +0900

In 
http://www6.jp.postgresql.org/users-lounge/docs/7.2/postgres/queries-limit.html

it is stated that the syntax is:

SELECT select_list
     FROM table_expression
     [LIMIT { number | ALL }] [OFFSET number]

This following query is valid even though the syntax is wrong:

select id from members order by id limit 5, 6

If this "alternative" syntax is acceptable could you add this 
alternative syntax to the docs? Else, the parser needs to throw an error?

SELECT select_list
     FROM table_expression
     [LIMIT { number | ALL }] [, [OFFSET] number]

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 7 Nov 2002 10:55:43 -0500 (EST)

Interesting you picked that up.  The comma for LIMIT was supported in
7.2.X only for backward compatibility, and was mentioned in the release
notes.  It is _not_ supported in 7.3 anymore, where the separate
LIMIT/OFFSET clauses are the only supported syntax.

---------------------------------------------------------------------------

Jean-Christian Imbeault wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 5: Have you checked our extensive FAQ?
> 
> http://www.postgresql.org/users-lounge/docs/faq.html
> 

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073