Subject: Re: Time input documentation error

From: Bruce Momjian <[email-masked]>
Date: Thu, 4 Sep 2003 22:45:41 -0400 (EDT)

Bruno Wolff III wrote:
> In table 8.11 in the 7.4 docs the following line:
> 040506         ISO 8601
> suggests that '040506' is a valid input format for time. But in fact
> it isn't accepted by either 7.3 or 7.4.
> 
> For example:
> area=> select '040506'::time;
> ERROR:  invalid input syntax for time: "040506"
> 
> I built using the intger datetimes option in case that makes a difference.

Seems it is fixed in CVS now:

	test=> select '040506'::time;
	   time
	----------
	 04:05:06
	(1 row)
t
-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: Bruno Wolff III <[email-masked]>
Date: Fri, 5 Sep 2003 14:11:14 -0500

On Thu, Sep 04, 2003 at 22:45:41 -0400,
> Seems it is fixed in CVS now:

I think Tom fixed it. He responded to my original message. I wasn't sure
if he was going to do the fix, but I found that it had been fixed at least
a week ago.