Subject: Re: Automatic compat checking? (was 7.4 compatibility question)

From: Christoph Haller <[email-masked]>
Date: Thu, 23 Oct 2003 11:01:16 METDST

> 
> On Wednesday 22 October 2003 07:37, Neil Conway wrote:
> > The second audience is the people who are really interested in exactly
> > what has changed between the new release of PostgreSQL and the previous
> > release series. It is important that we make it easy for an admin
> > planning a PostgreSQL upgrade at a fairly large site to be able to see
> > what changes in PostgreSQL have been made, and what changes will be
> > necessary in their own applications. 
> 
> Something I was pondering the other day was whether a pg_compat_chk utility 
> would be practical/desirable. You run it against your existing database / 
> schema dump and it prints a set of warnings:
> 
> Old version = 7.2.1
> New version = 7.4.0
> 
> Warning: schema support introduced (v7.3)
>   all objects will be placed in the default schema
> Failure: DEFAULT 'now' not supported (v7.4)
>   table1.column2
>   table2.column3
> Notice: timestamp now holds milliseconds by default (v7.3)
>   tableX.whatever
> 
> My main concern would be that a 90% solution might be worse than nothing at 
> all.
> Incidentally, this is not idle speculation, but something I might well have 
> time to stick in gborg during the 7.5 devt cycle.
> 
> -- 
>   Richard Huxton
>   Archonet Ltd
> 
A pg_compat_chk utility sounds great. 
No idea, if this is practical, but it's desirable - at least to me. 

Regards, Christoph 

PS I'm surprised no one else replied.

---

From: Richard Huxton <[email-masked]>
Date: Wed, 22 Oct 2003 10:30:52 +0100

Old version = 7.2.1
New version = 7.4.0

-- 
  Richard Huxton
  Archonet Ltd

---

From: Richard Huxton <[email-masked]>
Date: Thu, 23 Oct 2003 11:06:55 +0100

> No idea, if this is practical, but it's desirable - at least to me.

Well, I'm confident the first 90% is practical just by running some regexps 
against a pg_dumped schema. It doesn't need to guarantee there's a problem, 
just say "here's something you want to check". And there are things you could 
probably never check convincingly (e.g. the queries in an application). It's 
that final 10% that makes me uncertain.

Maybe it'd be enough to just list "tests I couldn't perform", at first anyway.

-- 
  Richard Huxton
  Archonet Ltd