Subject: adding GUC variable xrefs

From: Neil Conway <[email-masked]>
Date: Sat, 06 Mar 2004 11:51:58 -0500

I'm planning to replace most of the <varname> tags enclosing GUC 
variables in the docs with <xref> tags that allow the user to directly 
jump to the documentation for that particular configuration variable 
(that also requires adding "id" and "xreflabel" attributes to the GUC 
var documentation). The "xreflabel" of a GUC var is just it's name, so 
the actual text that is generated should be the same (the presentation 
will be a little different though).

This is part of a general project to add more cross-references to our 
documentation, so that we take better advantage of the hypertext 
nature of HTML (and PDF, although I'm not sure if the PDF versions of 
our docs support links -- in theory they could...)

Unless anyone objects, I'll start making the necessary changes soon. 
An example of the kind of change I'm planning is attached as a patch.

-Neil
Index: doc/src/sgml/perform.sgml
===================================================================
RCS file: /var/lib/cvs/pgsql-server/doc/src/sgml/perform.sgml,v
retrieving revision 1.41
diff -c -r1.41 perform.sgml
*** a/doc/src/sgml/perform.sgml	3 Feb 2004 17:34:02 -0000	1.41
--- b/doc/src/sgml/perform.sgml	5 Mar 2004 21:04:44 -0000
***************
*** 548,556 ****
    </para>
  
    <para>
!    To force the planner to follow the <literal>JOIN</> order for inner joins,
!    set the <varname>join_collapse_limit</> run-time parameter to 1.
!    (Other possible values are discussed below.)
    </para>
  
    <para>
--- 548,556 ----
    </para>
  
    <para>
!    To force the planner to follow the <literal>JOIN</> order for inner
!    joins, set the <xref linkend="guc-join-collapse-limit"> run-time
!    parameter to 1.  (Other possible values are discussed below.)
    </para>
  
    <para>
Index: doc/src/sgml/runtime.sgml
===================================================================
RCS file: /var/lib/cvs/pgsql-server/doc/src/sgml/runtime.sgml,v
retrieving revision 1.243
diff -c -r1.243 runtime.sgml
*** a/doc/src/sgml/runtime.sgml	1 Mar 2004 17:58:39 -0000	1.243
--- b/doc/src/sgml/runtime.sgml	5 Mar 2004 21:04:19 -0000
***************
*** 1586,1592 ****
        </listitem>
       </varlistentry>
  
!      <varlistentry>
        <term><varname>join_collapse_limit</varname> (<type>integer</type>)</term>
        <listitem>
         <para>
--- 1586,1592 ----
        </listitem>
       </varlistentry>
  
!      <varlistentry id="guc-join-collapse-limit" xreflabel="join_collapse_limit">
        <term><varname>join_collapse_limit</varname> (<type>integer</type>)</term>
        <listitem>
         <para>

---

From: Josh Berkus <[email-masked]>
Date: Mon, 8 Mar 2004 12:14:44 -0800

Neil,

> will be a little different though).

Please do.  I was working on this and got hung up on the broken SGML libs on 
my laptop.   (which are still broken, ^&$^@# SuSE!).

-- 
-Josh Berkus
 Aglio Database Solutions
 San Francisco