Subject: PostgreSQL.conf / runtime docs

From: Josh Berkus <[email-masked]>
Date: Fri, 6 Aug 2004 09:42:25 -0700

Folks,

I want to put some serious work into these.   However, I won't have all the 
data I need to update them until we're close to release; I need to do some 
serious performance testing on 8.0beta so that I can have actual numbers to 
recommend.

As we've always accepted doc patches up until a few days before release, this 
shouldn't be a problem, yes?  (Besides, I still need to fix the SGML 
libraries on my laptop ... )

-- 
Josh Berkus
Aglio Database Solutions
San Francisco

---

From: Tom Lane <[email-masked]>
Date: Fri, 06 Aug 2004 13:14:46 -0400

Josh Berkus <[email-masked]> writes:
> As we've always accepted doc patches up until a few days before
> release, this shouldn't be a problem, yes?

I'd be really surprised if anyone wants to change that policy.

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 6 Aug 2004 15:25:03 -0400 (EDT)

> I'd be really surprised if anyone wants to change that policy.

Agreed.  We take doc improvements anytime!

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: Peter Eisentraut <[email-masked]>
Date: Mon, 9 Aug 2004 19:40:25 +0200

Josh Berkus wrote:
> release, this shouldn't be a problem, yes?  (Besides, I still need to
> fix the SGML libraries on my laptop ... )

If you plan to do major outline reorganizations, I suggest that you do 
them somewhat sooner than a few days before release, because there is 
also a release management effort involved in the documentation.  But 
you can always plug in your latest measurements any time.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

---

From: Josh Berkus <[email-masked]>
Date: Mon, 9 Aug 2004 13:53:59 -0700

Peter,

> you can always plug in your latest measurements any time.

No massive re-org, we did that last version.

No, here's what I want to do:

1) add a new section at the top of the docs describing the most common options 
that people want to set on a new installation.
2) Add notes to each item about how to decide what to set it at.
3) Add label/values for:
	Default Value:
	Set At: (when you can change it)
	(this latter information is there but buried in the text; it would be better 	
	put on a seperate line)
4) add notes regarding version changes (like that work_mem used to be 
sort_mem, and that add_missing_from will default to "false" next version)

Your recommendations on tagging stuff are highly welcome; I'm still 
uncomfortable with SGML.

-- 
Josh Berkus
Aglio Database Solutions
San Francisco