Subject: Patch for plpgsql.sgml

From: Devrim GUNDUZ <[email-masked]>
Date: Fri, 6 Aug 2004 21:50:25 +0300 (EEST)

Hi,

As Tom has pointed out today, I've began reading the docs. plpgsql.sgml 
says that PostgreSQL does not support nested transactions. I've removed 
that part and a small diff is attached.

I'll be on 10-days' holiday and I'll try to read the whole docs.

Regards,
- -- 
Devrim GUNDUZ	       
devrim~gunduz.org				devrim.gunduz~linux.org.tr 
			http://www.tdmsoft.com
			http://www.gunduz.org
--- doc/src/sgml/plpgsql.sgml.orig	2004-08-06 12:05:10.000000000 +0300
+++ doc/src/sgml/plpgsql.sgml	2004-08-06 12:05:47.000000000 +0300
@@ -450,9 +450,7 @@
      grouping statements in <application>PL/pgSQL</> with the database commands for
      transaction control.  <application>PL/pgSQL</>'s <command>BEGIN</>/<command>END</> are only for grouping;
      they do not start or end a transaction.  Functions and trigger procedures
-     are always executed within a transaction established by an outer query
-     --- they cannot start or commit transactions, since
-     <productname>PostgreSQL</productname> does not have nested transactions.
+     are always executed within a transaction established by an outer query.
     </para>
   </sect1>

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 7 Aug 2004 21:55:25 -0400 (EDT)

Thanks, but I think Tom already fixed it.

---------------------------------------------------------------------------

Devrim GUNDUZ wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> Hi,
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.1 (GNU/Linux)
> 
> iD8DBQFBE9Lztl86P3SPfQ4RAtN9AKDjSR6Xlgl3ea2su1pDgOnsd1q27ACeLvT+
> aeF83FCl8/3ccbCdauwt6Wg=
> =Oks/
> -----END PGP SIGNATURE-----

Content-Description: 

[ Attachment, skipping... ]

> 
> ---------------------------(end of broadcast)---------------------------
> TIP 2: you can get off all lists at once with the unregister command
>     (send "unregister YourEmailAddressHere" to [email-masked])

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: Tom Lane <[email-masked]>
Date: Sat, 07 Aug 2004 21:57:21 -0400

> that part and a small diff is attached.

I've incorporated this in my recent commit.  Thanks.

			regards, tom lane