Subject: Getting Started Example for FC2

From: "James Armstrong" <[email-masked]>
Date: Tue, 24 Aug 2004 16:53:51 -0700

Hello,

I've just installed postgreSQL on my Fedora Core 2 system and found myself 
back in a position that I was in right after I installed it on Redhat.  As 
before, I was wondering how much of the documented source-to-execution 
intallation procedure was already done by the RPM install and by 
implication, what my next step should or could be.  Also, I was not finding 
things in the same locations that they were in on my RHEL system, possibly 
because I did do a "from-source" install there at one time.  I resolved to 
take notes this time.  I'm offering you the results so you can put it in the 
FAQ under the heading: "I just installed my RPMs on FC2.  Now what?"

Getting started with postgresql on Fedora Core 2

This is what you can do right after you have installed
postgreSQL on your Fedora Core 2 system with a command like:

yum install postgresql*

Step 1: Start the postgreSQL daemon.

(For GNOME use the "[RED HAT]^System Settings>Server Settings>Services"
menu item to start the Service Configuration application.  Then make sure
the [] postgresql item is checked in the list on the left side of the
Service Configuration application window.
If you had to change the item to make it checked, hit the "Save" button.

if you don't see something like:

postmaster (pid 4479 4478 4474) is running...

in the status box hit the start button while the
[] postgesql item is still highlighted.)

Step 2: Create a database for yourself.

[whomever@wherever whomever]$ su
Password:
[root@wherever whomever]# su - postgres
-bash-2.05b$ createdb test
CREATE DATABASE
-bash-2.05b$ psql test
Welcome to psql 7.4.2, the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help on internal slash commands
       \g or terminate with semicolon to execute query
       \q to quit

test=# CREATE USER whomever;
CREATE USER

test=# CREATE DATABASE whomever;
CREATE DATABASE

test=# GRANT ALL PRIVILEGES ON DATABASE whomever TO whomever;
GRANT

test=# \q
-bash-2.05b$ exit
logout
[root@wherever whomever]# exit
exit
[whomever@wherever whomever]$ psql
Welcome to psql 7.4.2, the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help on internal slash commands
       \g or terminate with semicolon to execute query
       \q to quit

whomever=> CREATE TABLE MY_TABLE (MY_COLUMN INTEGER);
CREATE TABLE
whomever=> INSERT INTO MY_TABLE(MY_COLUMN) VALUES(1);
INSERT 17146 1
whomever=> SELECT * FROM MY_TABLE;
my_column
-----------
         1
(1 row)

whomever=> \q
[whomever@wherever whomever]$

---

From: Robert Treat <[email-masked]>
Date: Tue, 24 Aug 2004 22:46:23 -0400

On Tuesday 24 August 2004 19:53, James Armstrong wrote:
> take notes this time.  I'm offering you the results so you can put it in
> the FAQ under the heading: "I just installed my RPMs on FC2.  Now what?"
>

ISTM this should go up onto techdocs rather than in the regular documentation? 
If there are no objections I'll put it on my todo list. 

-- 
Robert Treat
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL