Subject: Re: Some developer FAQ links need updating

From: Bruce Momjian <[email-masked]>
Date: Thu, 14 Oct 2004 17:19:13 -0400 (EDT)

Thanks.  I have updated it to:
	
	1.12) Where can I get a copy of the SQL standards?
	
	There are two major standards, SQL92 and SQL99. These standards are
	endorsed by ANSI and ISO. A draft of the SQL92 standard is available at
	http://www.contrib.andrew.cmu.edu/~shadow/sql/sql1992.txt. A draft of
	the SQL99 standard is at
	http://www.cse.iitb.ac.in/dbms/Data/Papers-Other/SQL1999/ansi-iso-9075-2-1999.pdf.
	The draft SQL 2003 standard is at
	http://www.wiscorp.com/sql/sql_2003_standard.zip
	
	Some SQL standards web pages are:
	
	    * http://troels.arvin.dk/db/rdbms/links/#standards
	    * http://www.wiscorp.com/SQLStandards.html
	    * http://www.contrib.andrew.cmu.edu/~shadow/sql.html#syntax (SQL92)
	    * http://dbs.uni-leipzig.de/en/lokal/standards.pdf (paper)

Also the Developer FAQ link on the developers page was out of date but
has just been fixed.

---------------------------------------------------------------------------

Troels Arvin wrote:
> Hello Bruce,
> 
> About http://developer.postgresql.org/readtext.php?src/FAQ/FAQ_DEV.html
> +Developers-FAQ#1.12 :
> 
> The section's first link could be more direct:
> http://www.contrib.andrew.cmu.edu/~shadow/sql.html#syntax
> 
> The sqlstandards.org FTP-sites seems to be either down (some of the
> time) or password-demanding (the rest of the time). I suggest that you
> link to http://www.wiscorp.com/SQLStandards.html or
> http://troels.arvin.dk/db/rdbms/links/#standards instead.
> 
> The http://db.konkuk.ac.kr/present/SQL3.pdf link has 404ed. I suggest
> adding http://www.acm.org/sigmod/record/issues/0403/index.html#standards
> instead.
> 
> -- 
> Greetings from Troels Arvin, Copenhagen, Denmark
> 

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: Alvaro Herrera <[email-masked]>
Date: Thu, 14 Oct 2004 18:27:26 -0300

On Thu, Oct 14, 2004 at 05:19:13PM -0400, Bruce Momjian wrote:
> 	There are two major standards, SQL92 and SQL99.

Ah, shouldn't this say "there are three major ..." if you are going to
give URLs for sql2003 ?

-- 
Alvaro Herrera (<alvherre[a]dcc.uchile.cl>)
"La soledad es compañía"

---

From: Troels Arvin <[email-masked]>
Date: Thu, 14 Oct 2004 23:30:41 +0200

Hello Bruce,

On Thu, 2004-10-14 at 17:19 -0400, Bruce Momjian wrote:
> I have updated it to:
> [...]

Great.
	
> 	There are two major standards, SQL92 and SQL99.

Shouldn't that be SQL-92 and SQL:2003, by the way? (SQL:2003 was
ratified early 2004.)

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 14 Oct 2004 17:49:20 -0400 (EDT)

> Shouldn't that be SQL-92 and SQL:2003, by the way? (SQL:2003 was

Updated.  I wasn't aware SQL:2003 was ratified.

New text is:

   There are three major standards: SQL-92, SQL:1999, and SQL:2003. 
   These standards are endorsed by ANSI and ISO. Draft
   versions can be download from:
     * SQL-92 http://www.contrib.andrew.cmu.edu/~shadow/sql/sql1992.txt
     * SQL:1999 http://www.cse.iitb.ac.in/dbms/Data/Papers-Other/SQL1999/ansi-iso-9075-2-1999.pdf
     * SQL:2003 http://www.wiscorp.com/sql/sql_2003_standard.zip

     * http://www.contrib.andrew.cmu.edu/~shadow/sql.html#syntax (SQL-92)

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 15 Oct 2004 00:19:21 +0200

>    There are three major standards: SQL-92, SQL:1999, and SQL:2003.

Actually, they are just different versions of the single major standard.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 14 Oct 2004 18:31:49 -0400 (EDT)

> Actually, they are just different versions of the single major standard.

Wording suggestion?

---

From: "Joshua D. Drake" <[email-masked]>
Date: Thu, 14 Oct 2004 18:36:26 -0700

>>Actually, they are just different versions of the single major standard.

There is only one current standard SQL:2003 correct? The rest are 
considered deprecated?

-- 
Command Prompt, Inc., home of Mammoth PostgreSQL - S/ODBC and S/JDBC
Postgresql support, programming shared hosting and dedicated hosting.
+1-503-667-4564 - [email-masked] - http://www.commandprompt.com
PostgreSQL Replicator -- production quality replication for PostgreSQL

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 14 Oct 2004 23:24:58 -0400 (EDT)

> There is only one current standard SQL:2003 correct? The rest are 

I don't think so.  Some database say they are SQL99-compliant while not
SQL-2003 compliant.

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 15 Oct 2004 14:09:32 +0200

> I don't think so.  Some database say they are SQL99-compliant while not

Clearly, consenting parties are free to agree on making their products conform 
to any standards document, be it old or new or deprecated or silly.  In the 
same way, someone could make a product that is certified for PostgreSQL 
7.2.1.  Or someone could write an HTML-compliant browser, only that it might 
be HTML 3.2.

Since we have limited resources, I think it's OK that we concentrate on 
working with the latest official standards version.  And because the latest 
standards version is modularized and has individual feature lists and 
packages, it would be a lot easier for us to look good, and it would be more 
useful for users to, say, specify a workable set of requirements for their 
applications.

Nevertheless, it would surely be useful to list SQL92 and SQL99 as older 
versions, just like many people still code to HTML 4.01 instead of XHTML 1.1, 
and just like many people still use PostgreSQL 7.2.1, inspite of it not 
conforming to any standard, as far as I know.

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 15 Oct 2004 12:10:11 -0400 (EDT)

OK, new wording:

    <P>There are three versions of the SQL standard:  SQL-92, SQL:1999,
    and SQL:2003.  They are endorsed by ANSI and ISO.  Draft versions
    can be download from:

Peter Eisentraut wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 5: Have you checked our extensive FAQ?
> 
>                http://www.postgresql.org/docs/faqs/FAQ.html
>

---

From: Josh Berkus <[email-masked]>
Date: Fri, 15 Oct 2004 09:19:46 -0700

Peter, Folks:

> packages, it would be a lot easier for us to look good, and it would be
> more useful for users to, say, specify a workable set of requirements for
> their applications.

FWIW, there's two standards that application developers are concerned with as 
far as I can tell: SQL92, which is the "stable" standard that ensures 
cross-database compatibility (as well as the only standard that is readable) 
and SQL2003, which is the current standard and ensures buzzowrd-compliance as 
well as future prospects.

-- 
Josh Berkus
Aglio Database Solutions
San Francisco

---

From: Tom Lane <[email-masked]>
Date: Fri, 15 Oct 2004 12:51:04 -0400

> There is only one current standard SQL:2003 correct? The rest are 

The old ones are certainly not "deprecated".

Personally I find the newer versions to be suffering from uncontrolled
feature bloat and committee-itis.

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 15 Oct 2004 12:53:01 -0400 (EDT)

> feature bloat and committee-itis.

That was my feeling too.  I know many cases the older specifications
were clearer.

Anyway, I think the new "There are three versions of the SQL standard"
wording is OK.