Subject: multimedia data storage issue

From: "Dariusz Dzingielewski" <[email-masked]>
Date: Thu, 4 Nov 2004 17:38:02 +0100

Hi,
     I'm a student of Gdansk University of Technology. Now I'm getting prepare to write my M.A. thesis. The topic of my work is "An interface in 
multimedia databases in radiology". One of the main tasks which I would like to do is to investigate how different database vendors store different 
multimedia data types. It includes data types like signals ( 1 and 2 - dimensional ), images, video sequences or 3d-objects. I'm searching for any kind of 
product documentation of leading database vendors (Oracle, PostgreSQL, MySql, Sybase, and others...) which concern on multimedia data storage problem (exactly: what data 
types they use to store multimedia data, what kind of data model they use to describe that data, what is the way of access to the data )    
 
Thanks a lot for any help!

best regards
Dariusz Dzingielewski
Gdansk University of Technology
Informatics in Medicine

---

From: Michael Fuhr <[email-masked]>
Date: Mon, 8 Nov 2004 22:51:40 -0700

On Thu, Nov 04, 2004 at 05:38:02PM +0100, Dariusz Dzingielewski wrote:

> I'm a student of Gdansk University of Technology. Now I'm getting
> prepare to write my M.A. thesis. The topic of my work is "An interface
> in multimedia databases in radiology". One of the main tasks which
> I would like to do is to investigate how different database vendors
> store different multimedia data types. It includes data types like
> signals ( 1 and 2 - dimensional ), images, video sequences or
> 3d-objects. I'm searching for any kind of product documentation of
> leading database vendors (Oracle, PostgreSQL, MySql, Sybase, and
> others...) which concern on multimedia data storage problem (exactly:
> what data types they use to store multimedia data, what kind of
> data model they use to describe that data, what is the way of access
> to the data )

PostgreSQL has built-in types to store binary data, some geometric
data, and arrays.  See the "Data Types" chapter in the PostgreSQL
documentation for the full story.

http://www.postgresql.org/docs/7.4/static/datatype.html

PostgreSQL allows users to create their own types, operators, and
aggregates, so if the built-in capabilities aren't adequate for a
particular application then users can extend the database as needed.

http://www.postgresql.org/docs/7.4/static/extend.html

You can see examples of extending PostgreSQL in the contrib directory
of the source code.

This may not be the specific information you seek, but it does
show that users can extend PostgreSQL to fit their needs.

-- 
Michael Fuhr
http://www.fuhr.org/~mfuhr/