Subject: FAQ and Windows

From: Ian Barwick <[email-masked]>
Date: Thu, 28 Oct 2004 22:34:27 +0200

Hi

I was trying to clarify the installation options for Windows and noticed
all mention of the Cygwin package has been dropped from the FAQ.
Attached is a patch mentioning this is the only option
for DOS-based Windows (95 ~ ME) - someone is bound to ask - and with links to 
the relevant FAQs. I also bumped the current version number.

On a related note I'd suggest adding the "Native Win32 FAQ"
( http://pginstaller.projects.postgresql.org/FAQ_windows.html ) to the
list at http://www.postgresql.org/docs/#faqs .

Ian Barwick
[email-masked]
Index: FAQ.html
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/FAQ/FAQ.html,v
retrieving revision 1.227
diff -c -r1.227 FAQ.html
*** FAQ.html	1 Sep 2004 03:28:15 -0000	1.227
--- FAQ.html	28 Oct 2004 20:26:00 -0000
***************
*** 242,248 ****
      Microsoft Windows NT-based operating systems like Win2000, WinXP,
      and Win2003.  A prepackaged installer is available at <a href=
      "http://pgfoundry.org/projects/pginstaller">
!     http://pgfoundry.org/projects/pginstaller</a>.
  
      <p>There is also a Novell Netware 6 port at
      <a href="http://forge.novell.com">http://forge.novell.com</a>.</p>
--- 242,255 ----
      Microsoft Windows NT-based operating systems like Win2000, WinXP,
      and Win2003.  A prepackaged installer is available at <a href=
      "http://pgfoundry.org/projects/pginstaller">
!     http://pgfoundry.org/projects/pginstaller</a>. A Windows-specific FAQ
!     is available at <a href="http://pginstaller.projects.postgresql.org/FAQ_windows.html">http://pginstaller.projects.postgresql.org/FAQ_windows.html</a>.</p>
! 
!     <p>PostgreSQL can also be installed on Windows using the Cygwin 
!     compatibility layer. Although not suitable for a production environment,
!     this is the only installation option for 16-bit Windows (95, 98 and ME).
!     The Cygwin FAQ (<a href="http://www.postgresql.org/docs/faqs/text/FAQ_CYGWIN">http://www.postgresql.org/docs/faqs/text/FAQ_CYGWIN</a>)
!     contains further information.</p>
  
      <p>There is also a Novell Netware 6 port at
      <a href="http://forge.novell.com">http://forge.novell.com</a>.</p>
***************
*** 315,321 ****
  
      <H4><A name="1.7">1.7</A>) What is the latest release?</H4>
  
!     <P>The latest release of PostgreSQL is version 7.4.5.</P>
  
      <P>We plan to have major releases every six to eight months.</P>
  
--- 322,328 ----
  
      <H4><A name="1.7">1.7</A>) What is the latest release?</H4>
  
!     <P>The latest release of PostgreSQL is version 7.4.6.</P>
  
      <P>We plan to have major releases every six to eight months.</P>

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 27 Nov 2004 00:19:46 -0500 (EST)

OK, I updated the FAQ by adding this sentence:

	MSDOS-based versions of Windows (Win95, Win98, WinMe) can run
	PostgreSQL using Cygwin.

I also updated the version number.

Magnus is going to update the pginstaller FAQ to talk about using Win32
and I am going to have the CVS Win32 FAQ talk about building on Win32,
and each FAQ is going to point to the other.  Magnus, FAQ_MINGW already
points to the pginstaller FAQ.  Can we complete the adjustement of these
FAQ's?

---------------------------------------------------------------------------

> list at http://www.postgresql.org/docs/#faqs .

[ Attachment, skipping... ]

> 
> ---------------------------(end of broadcast)---------------------------
> TIP 3: if posting/reading through Usenet, please send an appropriate
>       subscribe-nomail command to [email-masked] so that your
>       message can get through to the mailing list cleanly

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073