Subject: Week numbering

From: Troels Arvin <[email-masked]>
Date: Mon, 06 Dec 2004 11:22:37 +0100

Hello,

I was recently surprised to find that EXTRACT's day of the week
numbering is different than TO_CHAR's ditto. EXTRACT starts at 0==Sunday
while TO_CHAR starts at 1==Sunday.

A suggestion for two documentation notes is attached as a patch to
current CVS HEAD.

-- 
Greetings from Troels Arvin, Copenhagen, Denmark
Index: doc/src/sgml/func.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/func.sgml,v
retrieving revision 1.229
diff -c -r1.229 func.sgml
*** doc/src/sgml/func.sgml	3 Dec 2004 18:34:31 -0000	1.229
--- doc/src/sgml/func.sgml	6 Dec 2004 10:16:57 -0000
***************
*** 4412,4417 ****
--- 4412,4424 ----
         1230 microseconds = 2.021230 seconds. 
        </para>
       </listitem>
+ 
+      <listitem>
+       <para><function>to_char</function>'s day of the week numbering
+         (see the 'D' formatting pattern) is different from that of the 
+         <function>extract</function> function.
+       </para>
+      </listitem>
      </itemizedlist>
     </para>
  
***************
*** 5146,5151 ****
--- 5153,5163 ----
  SELECT EXTRACT(DOW FROM TIMESTAMP '2001-02-16 20:38:40');
  <lineannotation>Result: </lineannotation><computeroutput>5</computeroutput>
  </screen>
+        <para>
+         Note that <function>extract</function>'s day of the week numbering is 
+         different from that of the <function>to_char</function> function.
+        </para>
+ 
        </listitem>
       </varlistentry>

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 20 Dec 2004 20:02:51 -0500 (EST)

Patch applied.  Thanks.

---------------------------------------------------------------------------

> A suggestion for two documentation notes is attached as a patch to

[ Attachment, skipping... ]

> 
> ---------------------------(end of broadcast)---------------------------
> TIP 7: don't forget to increase your free space map settings

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073