Subject: Update "Requirements" for Windows?

From: Tom Lane <[email-masked]>
Date: Fri, 24 Dec 2004 12:43:02 -0500

In the Administrator's Guide, first section under Installation, it still
says

* To build on Windows NT or Windows 2000 you need the Cygwin and cygipc
  packages. See the file doc/FAQ_MSWIN for details.

I suppose this is at least partly out of date, but what should it say
now?

Also, do we even still need the "Installation on Windows" section?  Is
anyone still going to care about building the frontend tools that way?

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 24 Dec 2004 13:12:37 -0500 (EST)

> anyone still going to care about building the frontend tools that way?

Oh, I see this needs some major restructuring/relabeling.  I am working
on that now.

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: Tom Lane <[email-masked]>
Date: Fri, 24 Dec 2004 13:28:46 -0500

> Oh, I see this needs some major restructuring/relabeling.  I am working

I'm already in process of copy-editing that file; please don't change it
under me.

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 24 Dec 2004 13:33:09 -0500 (EST)

> I'm already in process of copy-editing that file; please don't change it

Oops.  I just committed. I will back it out.  Let me know when you are
done.

---

From: Tom Lane <[email-masked]>
Date: Fri, 24 Dec 2004 13:34:06 -0500

> I'm already in process of copy-editing that file; please don't change it

Actually, as long as you're only touching installw.sgml and not
install.sgml, there's no problem.  May I suggest that the material
in FAQ_MINGW and FAQ_CYGWIN might be transposed into that chapter?

			regards, tom lane

---

From: Tom Lane <[email-masked]>
Date: Fri, 24 Dec 2004 13:36:30 -0500

> Oops.  I just committed. I will back it out.  Let me know when you are

Never mind then, I'll merge ...

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 24 Dec 2004 13:40:50 -0500 (EST)

> in FAQ_MINGW and FAQ_CYGWIN might be transposed into that chapter?

I was touching both so I will wait.  We could move the FAQ info into the
docs but in a way the FAQ_MINGW doc file is referenced by both
pginstaller and by the docs, so merging it in might not make sense, and
it does have totally platform-specific stuff that might appear too large
in the official docs.

Right now in my current patch the idea is that in installation.sgml we
point them to FAQ_MINGW or FAQ_CYGWIN and from there they would get the
tools they need and return to the official install docs to complete the
job.

---

From: Tom Lane <[email-masked]>
Date: Fri, 24 Dec 2004 14:13:14 -0500

OK, I'm out of installation.sgml if you want to have another hack at it.

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 24 Dec 2004 14:20:37 -0500 (EST)

> OK, I'm out of installation.sgml if you want to have another hack at it.

OK, diff attached and applied.

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073
Index: doc/src/sgml/install-win32.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/install-win32.sgml,v
retrieving revision 1.20
diff -c -c -r1.20 install-win32.sgml
*** doc/src/sgml/install-win32.sgml	24 Dec 2004 18:37:26 -0000	1.20
--- doc/src/sgml/install-win32.sgml	24 Dec 2004 19:18:42 -0000
***************
*** 3,9 ****
  -->
  
  <chapter id="install-win32">
!  <title>Installation on <productname>Windows</productname></title>
  
   <indexterm>
    <primary>installation</primary>
--- 3,9 ----
  -->
  
  <chapter id="install-win32">
!  <title>Client-Only Installation on <productname>Windows</productname></title>
  
   <indexterm>
    <primary>installation</primary>
***************
*** 12,19 ****
  
   <para>
    Although <productname>PostgreSQL</productname> is written for
!   Unix-like operating systems and compiles under
!   <productname>MinGW</productname>, the C client library
    (<application>libpq</application>) and the interactive terminal
    (<application>psql</application>) can be compiled using other Windows
    tool sets. Makefiles are included in the source distribution for
--- 12,20 ----
  
   <para>
    Although <productname>PostgreSQL</productname> is written for
!   Unix-like operating systems and can be built using
!   <productname>MinGW</productname> and
!   <productname>Cygwin</productname>, the C client library
    (<application>libpq</application>) and the interactive terminal
    (<application>psql</application>) can be compiled using other Windows
    tool sets. Makefiles are included in the source distribution for
Index: doc/src/sgml/installation.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/installation.sgml,v
retrieving revision 1.219
diff -c -c -r1.219 installation.sgml
*** doc/src/sgml/installation.sgml	24 Dec 2004 19:12:36 -0000	1.219
--- doc/src/sgml/installation.sgml	24 Dec 2004 19:18:46 -0000
***************
*** 120,129 ****
         <secondary>on Windows</secondary>
        </indexterm>
  
!       To build on <productname>Windows NT</> or <productname>Windows
!       2000</> you need the <productname>Cygwin</> and
!       <productname>cygipc</> packages. See the file
!       <filename>doc/FAQ_MSWIN</> for details.
       </para>
      </listitem>
     </itemizedlist>
--- 120,136 ----
         <secondary>on Windows</secondary>
        </indexterm>
  
!       To build on <productname>NT</>-based versions of
!       <productname>Windows</> like Windows XP and 2003 see
!       <filename>doc/FAQ_MINGW</>. For earlier <productname>Windows</>
!       releases see <filename>doc/FAQ_CYGWIN</>.
! 
!       To build <productname>Windows</> client-only interfaces using
!       tools like <productname>Visual C++</> and <productname>Borland
!       C++</> see
!       <![%standalone-include[the documentation chapter "Client-Only
!       Installation on Windows"]]> <![%standalone-ignore[<xref
!       linkend="install-win32">]]>.
       </para>
      </listitem>
     </itemizedlist>