Subject: Windows 2000 Slower Than Windows XP

From: "Quinton Lawson" <[email-masked]>
Date: Sat, 22 Jan 2005 19:57:50 -0600

I have been having quite a time trying to figure this one out.  I have installed PostgreSQL OLE DB drivers (ver 1.0.0.15) on two separate machines.  The only difference between the two machines is the OS, 2000 Pro (SP4) and XP Pro (SP2) and both are fully updated from fresh installs.  The PostgreSQL 8.0 server is running on another Windows XP Pro machine (SP2, fully updated).

I am performing a Select query like this: 
SELECT column1, column2, column3 FROM table1 WHERE column4 = 'value1' AND column5 ='value2' ORDER BY column1, column2;

Connection String:
Provider=PostgreSQL.1;Password="";User ID=client1;Data Source=server;Location=Media Database;Extended Properties=""

The results take approximately 2 seconds on the XP machine and 8 seconds on the 2000 machine.

Explain Analyze yields nearly identical times (45ms) between the two.

Any ideas why this is occuring?

Thank You,
qlawson

---

From: Joe Audette <[email-masked]>
Date: Sat, 22 Jan 2005 19:47:09 -0800 (PST)

Sounds like it could be a networking issue to me.
Perhaps the xp machine is resolving the db server name
more efficiently.
do both the xp machine and the win2k machine
1 have comparable network cards?
2 on the same subnet as each other and the db?
3 using the same dns or wins server?

you could try putting an entry in the hosts file on
the slow machine to resolve the name of the db machine
and see if that helps.

I'm no expert on Postgre SQL so maybe there is a
driver difference or something that others on the list
would know better.

Hope that helps,

Joe

--- Quinton Lawson <[email-masked]> wrote:

> I have been having quite a time trying to figure
> this one out.  I have installed PostgreSQL OLE DB
> drivers (ver 1.0.0.15) on two separate machines. 
> The only difference between the two machines is the
> OS, 2000 Pro (SP4) and XP Pro (SP2) and both are
> fully updated from fresh installs.  The PostgreSQL
> 8.0 server is running on another Windows XP Pro
> machine (SP2, fully updated).
> 
> SELECT column1, column2, column3 FROM table1 WHERE
> column4 = 'value1' AND column5 ='value2' ORDER BY
> column1, column2;
> 
> Connection String:
> Provider=PostgreSQL.1;Password="";User
> ID=client1;Data Source=server;Location=Media
> Database;Extended Properties=""
> 
> The results take approximately 2 seconds on the XP
> machine and 8 seconds on the 2000 machine.
> 

=====
[email-masked]
http://www.joeaudette.com
http://www.mojoportal.com

__________________________________ 
Do you Yahoo!? 
Read only the mail you want - Yahoo! Mail SpamGuard. 
http://promotions.yahoo.com/new_mail

---

From: "Quinton Lawson" <[email-masked]>
Date: Sat, 22 Jan 2005 22:25:30 -0600

Thank you Joe for leading me in the right direction.  I found the solution to the problem.  It wasn't a hardware related problem or an OLE DB driver problem...  

By default, Windows XP installs the QoS Packet Scheduler service.  It is not installed by default on Windows 2000.  After I installed QoS Packet Scheduler on the Windows 2000 machine, the latency problem vanished.

I am a happy PostgreSQL user now :)

-qlawson

  ----- Original Message ----- 
  From: Joe Audette 
  To: [email-masked] 
  Sent: Saturday, January 22, 2005 9:47 PM
  Subject: Re: [GENERAL] Windows 2000 Slower Than Windows XP

  Hope that helps,

  Joe

  =====
  [email-masked]

  ---------------------------(end of broadcast)---------------------------
  TIP 6: Have you searched our list archives?

                 http://archives.postgresql.org

---

From: Alvaro Herrera <[email-masked]>
Date: Sun, 23 Jan 2005 11:35:48 -0300

On Sat, Jan 22, 2005 at 10:25:30PM -0600, Quinton Lawson wrote:

> By default, Windows XP installs the QoS Packet Scheduler service.  It
> is not installed by default on Windows 2000.  After I installed QoS
> Packet Scheduler on the Windows 2000 machine, the latency problem
> vanished.

Maybe this deserves a FAQ entry or doc note somewhere.

-- 
Alvaro Herrera (<alvherre[@]dcc.uchile.cl>)
"Estoy de acuerdo contigo en que la verdad absoluta no existe...
El problema es que la mentira sí existe y tu estás mintiendo" (G. Lama)

---

From: Lincoln Yeoh <[email-masked]>
Date: Sun, 23 Jan 2005 23:34:44 +0800

While not an FAQ (yet?) I find it interesting that installing a QoS packet 
scheduler would _improve_ response - (I'm assuming there's no other 
concurrent traffic other than DB traffic).

Anyone know why this would be the case or have any ideas? Might it improve 
performance for other network software as well...

Regards,
Link.