Subject: A Question

From: jsona laio <[email-masked]>
Date: Fri, 21 Jan 2005 15:57:13 +0000 (GMT)

I have a question, but I have no idea weahter I should
ask it here (If not, I apologize and hope someone
could tell me where to post this message or kindly to
forward it to right place, thank you; ). My question
is "May I translate postgresql to my native
language?." For I do not see any message about this in
FAQ or mailinglist(Perhaps there's but I didn't see
it.) If I can, how or what steps I need to do to help
translate mannual of postgresql to the langauge of
mine?
I appreciate it, sincerely.
Arsene

___________________________________________________________ 
ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com

---

From: Alvaro Herrera <[email-masked]>
Date: Sat, 22 Jan 2005 01:59:03 -0300

On Fri, Jan 21, 2005 at 03:57:13PM +0000, jsona laio wrote:

> My question is "May I translate postgresql to my native language?."
> For I do not see any message about this in FAQ or mailinglist (Perhaps
> there's but I didn't see it.) If I can, how or what steps I need to do
> to help translate mannual of postgresql to the langauge of mine?

You certainly can try.  Whether a one-man effort is going to succeed
is completely up to you.  The french translation is a group effort and
AFAIK they are not yet finished (and it appears that it is stalled);
in contrast, the german translation is a one-man effort and it was
finished in three months.

I suggest you take a look at how the french guys are doing it.  The
website about it (in french) is http://traduc.postgresqlfr.org.

A different question is whether you can translate Postgres itself.  See 
http://developer.postgresql.org/~petere/nlsinfo/

-- 
Alvaro Herrera (<alvherre[@]dcc.uchile.cl>)
"La conclusión que podemos sacar de esos estudios es que
no podemos sacar ninguna conclusión de ellos" (Tanenbaum)

---

From: Guillaume LELARGE <[email-masked]>
Date: Sat, 22 Jan 2005 09:14:35 +0100

> finished in three months.

Actually, it isn't stalled at all. We are nearly done for 7.4.0 release. 
Three files (docguide, ecpg and xindex) remain to be translated (see 
http://traduc.postgresqlfr.org/reservmanuel.html for up to date news). 
We hope we can have the complete translation at the end of January.

We will then update to 7.4.6 release and finally to 8.0 release. There's 
  still a lot of work to do :)

For the german translation, don't forget it was done by one man, working 
three months *full time* on it. And still I don't understand how Peter 
was able to accomplish this in a such short period. I'm really impressed.

> website about it (in french) is http://traduc.postgresqlfr.org.

Or ask directly to me.

-- 
Guillaume.
<!-- http://abs.traduc.org/
      http://lfs.traduc.org/
      http://traduc.postgresqlfr.org/ -->

---

From: neo anderson <[email-masked]>
Date: Sun, 23 Jan 2005 15:31:39 +0000 (GMT)

Hi, thanks for all your reply.
I originally planned to translate the manual of the
postgresql
[http://www.postgresql.org/docs/8.0/static/index.html].
Though seemly there's translation already [of my
native language], but it's out of dated [and I still
get no reply before I post this message]. Therefore, I
may go with a li'l step as possible(  though I'm not
Peter; ) to translate the manual of version 8.0.
However, I have no idea wheather to submit translated
document because I have no website to hooked on. Is it
possible to submit it to postgresql doc team? or what
should I do?
I appreciate it, sincerely.
Arsene

---

From: Alvaro Herrera <[email-masked]>
Date: Sun, 23 Jan 2005 22:47:03 -0300

> possible to submit it to postgresql doc team? or what

We currently don't have a place to store translated manuals.  I think we
(or you) could set something up, maybe a project in pgfoundry.

Ideally I'd like a centralized system where all translations could be
kept and managed.  But I don't like the idea of just translating the
SGML and storing the translation as plain HTML or SGML, because it's
very difficult to keep it up to date; that's the problem you are having
with the old translation to your language, for example, as I have with
the old spanish translation.

For some time already I have wanted to work on a system that would allow
you to keep the translation up to date easily, maybe involving XLIFF and
a database.  So you would consult the system and it would show you what
you have to translate to take the manual from 7.4 to 8.0, without having
to look at gigantic and unreadable diffs.

But I haven't done anything about it yet.

-- 
Alvaro Herrera (<alvherre[@]dcc.uchile.cl>)
"Cada quien es cada cual y baja las escaleras como quiere" (JMSerrat)

---

From: Guillaume LELARGE <[email-masked]>
Date: Mon, 24 Jan 2005 09:15:03 +0100

> But I haven't done anything about it yet.

There's po4a (http://po4a.alioth.debian.org/). It builds po files from 
sgml files. But I don't know if it can work on big documentations.

---

From: Alvaro Herrera <[email-masked]>
Date: Mon, 24 Jan 2005 22:26:56 -0300

> >a database.

Personally I hate PO files.  So I rejected the xml2po solution some time
ago (which Gnome and KDE use).

Then again, maybe my problem is not PO files, but rather the tools to
handle them.  I hate them so passionately that I edit them with vim
instead.  I'm too lazy to come up with another one, of course.

-- 
Alvaro Herrera (<alvherre[@]dcc.uchile.cl>)
"Linux transformó mi computadora, de una `máquina para hacer cosas',
en un aparato realmente entretenido, sobre el cual cada día aprendo
algo nuevo" (Jaime Salinas)