Subject: question about markup

From: Robert Treat <[email-masked]>
Date: Mon, 28 Feb 2005 22:04:01 -0500

someone suggested that the insert command at the end of 
http://wwwmaster.postgresql.org/docs/8.0/interactive/dml.html  would be 
better if it were a link like the copy command is.  Is there some reason not 
to make it a link? I notice most commands are not done this way. 

-- 
Robert Treat
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: Neil Conway <[email-masked]>
Date: Wed, 02 Mar 2005 10:46:26 +1100

Robert Treat wrote:
> to make it a link?

No particular reason. I've applied the following patch to head; it makes 
the first reference to "INSERT" in that page an xref, as well as making 
a few other minor improvements.

> I notice most commands are not done this way. 

Yeah, there's not much point linking each and every reference to a SQL 
command.

-Neil

Index: doc/src/sgml/dml.sgml
===================================================================
RCS file: /var/lib/cvs/pgsql/doc/src/sgml/dml.sgml,v
retrieving revision 1.10
diff -c -r1.10 dml.sgml
*** doc/src/sgml/dml.sgml	22 Jan 2005 22:56:35 -0000	1.10
--- doc/src/sgml/dml.sgml	1 Mar 2005 23:39:45 -0000
***************
*** 38,47 ****
    </para>
  
    <para>
!    To create a new row, use the <literal>INSERT</literal> command.
!    The command requires the table name and a value for each of the
!    columns of the table.  For example, consider the products table
!    from <xref linkend="ddl">:
  <programlisting>
  CREATE TABLE products (
      product_no integer,
--- 38,47 ----
    </para>
  
    <para>
!    To create a new row, use the <xref linkend="sql-insert"
!    xreflabel="sql-insert-title"> command.  The command requires the
!    table name and a value for each of the columns of the table.  For
!    example, consider the products table from <xref linkend="ddl">:
  <programlisting>
  CREATE TABLE products (
      product_no integer,
***************
*** 98,104 ****
      To do <quote>bulk loads</quote>, that is, inserting a lot of data,
      take a look at the <xref linkend="sql-copy"
      endterm="sql-copy-title"> command.  It is not as flexible as the
!     <command>INSERT</command> command, but is more efficient.
     </para>
    </tip>
   </sect1>
--- 98,106 ----
      To do <quote>bulk loads</quote>, that is, inserting a lot of data,
      take a look at the <xref linkend="sql-copy"
      endterm="sql-copy-title"> command.  It is not as flexible as the
!     <command>INSERT</command> command, but is more efficient. Refer to
!     <xref linkend="populate"> for more information on improving bulk
!     loading performance.
     </para>
    </tip>
   </sect1>
***************
*** 188,194 ****
  
    <para>
     You can update more than one column in an
!    <literal>UPDATE</literal> command by listing more than one
     assignment in the <literal>SET</literal> clause.  For example:
  <programlisting>
  UPDATE mytable SET a = 5, b = 3, c = 1 WHERE a &gt; 0;
--- 190,196 ----
  
    <para>
     You can update more than one column in an
!    <command>UPDATE</command> command by listing more than one
     assignment in the <literal>SET</literal> clause.  For example:
  <programlisting>
  UPDATE mytable SET a = 5, b = 3, c = 1 WHERE a &gt; 0;
***************
*** 222,230 ****
    </para>
  
    <para>
!    You use the <literal>DELETE</literal> command to remove rows; the
!    syntax is very similar to the <literal>UPDATE</literal> command.
!    For instance, to remove all rows from the products table that have a price of 10, use
  <programlisting>
  DELETE FROM products WHERE price = 10;
  </programlisting>
--- 224,234 ----
    </para>
  
    <para>
!    You use the <xref linkend="sql-delete"
!    xreflabel="sql-delete-title"> command to remove rows; the syntax is
!    very similar to the <command>UPDATE</command> command.  For
!    instance, to remove all rows from the products table that have a
!    price of 10, use
  <programlisting>
  DELETE FROM products WHERE price = 10;
  </programlisting>

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 17 Mar 2005 15:24:35 -0500 (EST)

> to make it a link? I notice most commands are not done this way. 

Done.

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073