Subject: Re: Two points about docs

From: Bruce Momjian <[email-masked]>
Date: Mon, 9 May 2005 21:50:16 -0400 (EDT)

Vladimir Chukharev wrote:
> On Sun, 08 May 2005 06:18:04 +0300, Bruce Momjian <[email-masked]> wrote:
> 
> > I have added your first two suggestions.   Not sure where to put the
> > large object links in the function section.  It seems out of place there
> > to me.
> 
> Thanks!
> 
> About the link to the lo_* functions. I thought about adding
> a sentence to Charpter 9 like 'And functions to manipulate large
> objects are presented in Charpter 28.' right after the phrase
> 'Users can also define their own functions and operators, as
> described in Part V.'
> 
> Do you think it's suitable?

Not really.  We don't mention pg_stat_activity functions either.  I
think people have to realize that some functions are covered in other
sections of the manual.  There is a clearly titled section for large
objeccts.

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: "Vladimir Chukharev" <[email-masked]>
Date: Wed, 11 May 2005 09:50:10 +0300

> sections of the manual.  There is a clearly titled section for large

OK, what about writing down this idea? "Not all functions are listed
in this Chapter, some are in other sections of the manual."

And I still think that an additional Appendix with a list of all
functions and referencies to their descriptions would be very usefull.
Can you comment on that?

Best regards,
-- 
V.Chukharev

---

From: Michael Glaesemann <[email-masked]>
Date: Wed, 11 May 2005 16:00:02 +0900

> functions and referencies to their descriptions would be very usefull.

This has been brought up in the past. I don't think there's any reason 
there can't be one. Want to make a function appendix? :)

Michael Glaesemann
grzm myrealbox com

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 11 May 2005 09:36:55 -0400 (EDT)

> in this Chapter, some are in other sections of the manual." 

OK, done.

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073
Index: doc/src/sgml/func.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/func.sgml,v
retrieving revision 1.245
diff -c -c -r1.245 func.sgml
*** doc/src/sgml/func.sgml	13 Apr 2005 00:20:10 -0000	1.245
--- doc/src/sgml/func.sgml	11 May 2005 13:32:41 -0000
***************
*** 32,38 ****
     <acronym>SQL</acronym> standard. Some of the extended functionality
     is present in other <acronym>SQL</acronym> database management
     systems, and in many cases this functionality is compatible and
!    consistent between the various implementations.
    </para>

--- 32,40 ----
     <acronym>SQL</acronym> standard. Some of the extended functionality
     is present in other <acronym>SQL</acronym> database management
     systems, and in many cases this functionality is compatible and
!    consistent between the various implementations.  This chapter is also
!    not exhaustive;  additional functions appear in relivant sections of 
!    the manual.
    </para>

---

From: Tom Lane <[email-masked]>
Date: Wed, 11 May 2005 09:39:08 -0400

> there can't be one. Want to make a function appendix? :)

I think this is more conventionally called an index ;-)

			regards, tom lane

---

From: Tom Lane <[email-masked]>
Date: Wed, 11 May 2005 09:59:52 -0400

> !    not exhaustive;  additional functions appear in relivant sections of 

"relevant", please.

			regards, tom lane

---

From: Michael Glaesemann <[email-masked]>
Date: Wed, 11 May 2005 23:01:10 +0900

> I think this is more conventionally called an index ;-)

Hehe :) Thanks, Tom! I don't know how the "i" and "e" got swapped 
around, and that initial "app" is a complete mystery to me. Have to 
check my mail software, I think. ;)

Michael Glaesemann
grzm myrealbox com

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 11 May 2005 10:05:20 -0400 (EDT)

> > !    not exhaustive;  additional functions appear in relivant sections of 

Yea, Neil got it.

---

From: "Vladimir Chukharev" <[email-masked]>
Date: Sun, 15 May 2005 17:34:53 +0300

> there can't be one. Want to make a function appendix? :)

OK, now I am trying to make the index. It will take time though, since
I can turn to it only when I'm _really sick_ with my PhD thesis :)

I made the list with psql \df command, and already found that
there is neither lo_write nor lo_read, but lowrite and loread instead...
Any idea what's wrong?

In addition I can find nothing about RI_FKey_* function.
Can you direct me please?

-- 
V.Chukharev