Subject: Two points about docs

From: "Vladimir Chukharev" <[email-masked]>
Date: Fri, 01 Apr 2005 09:17:12 +0300

Hi,

I think that docs can be improved a bit in two places.

1. Description of SELECT ( http://www.postgresql.org/docs/8.0/static/sql-select.html )
says 'SELECT retrieves rows from one or more tables.' This is not perfectly
correct, because 0 tables can be used like in 'SELECT 1;'. When I tried to find
how I can check the meaning of some simple function, at first attempt I really
thought that SELECT cannot be used without tables.

Chapter 7.1 also says that the simpleast query is 'SELECT * FROM table1;',
but at least the example 'SELECT 3 * 4;' is close enough to catch an eye.

2. 'Chapter 9. Functions and Operators' has no reference to server side
functions for large object manipulation (lo_creat et al.) Yesterday wanted
to check the names of those functions (I remembered there are some in psql).
So, first I found that blob is a keyword, but is not implemented. Then I tried
to find them in Chapter 9. I just couldn't beleave it's not there. Then I tried
to find a list of all functions, similar to list of all keywords. And only
after all that I found the location of the lo_* functions.

Well, may it is just me, of course. I don't know...

-- 
V.Chukharev

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 7 May 2005 23:18:04 -0400 (EDT)

I have added your first two suggestions.   Not sure where to put the
large object links in the function section.  It seems out of place there
to me.

---------------------------------------------------------------------------

Vladimir Chukharev wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 8: explain analyze is your friend
> 

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073
Index: doc/src/sgml/queries.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/queries.sgml,v
retrieving revision 1.33
diff -c -c -r1.33 queries.sgml
*** doc/src/sgml/queries.sgml	22 Jan 2005 22:56:36 -0000	1.33
--- doc/src/sgml/queries.sgml	8 May 2005 03:07:04 -0000
***************
*** 34,40 ****
    </para>
  
    <para>
!    The simplest kind of query has the form
  <programlisting>
  SELECT * FROM table1;
  </programlisting>
--- 34,40 ----
    </para>
  
    <para>
!    A simple kind of query has the form
  <programlisting>
  SELECT * FROM table1;
  </programlisting>
Index: doc/src/sgml/ref/select.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/ref/select.sgml,v
retrieving revision 1.86
diff -c -c -r1.86 select.sgml
*** doc/src/sgml/ref/select.sgml	28 Apr 2005 21:47:10 -0000	1.86
--- doc/src/sgml/ref/select.sgml	8 May 2005 03:07:06 -0000
***************
*** 47,53 ****
    <title>Description</title>
  
    <para>
!    <command>SELECT</command> retrieves rows from one or more tables.
     The general processing of <command>SELECT</command> is as follows:
  
     <orderedlist>
--- 47,53 ----
    <title>Description</title>
  
    <para>
!    <command>SELECT</command> retrieves rows from zero or more tables.
     The general processing of <command>SELECT</command> is as follows:
  
     <orderedlist>