Subject: Generate Windows MO files in Linux

From: Halley Pacheco de Oliveira <[email-masked]>
Date: Fri, 10 Jun 2005 08:14:15 -0300 (ART)

I use PostgreSQL 8.0.1 in Windows, so I did a download of postgresql-8.0.1.tar.gz file using
Linux, edited the pt_BR.po translation for psql using KBabel, generate the psql.mo file using
"msgfmt --statistic -v -c -o psql.mo pt_BR.po" which returned "496 messages translateds", and
moved the psql.mo file to E:\Program Files\PostgreSQL\8.0\share\locale\pt_BR\LC_MESSAGES\psql.mo
in Windows.

It is working fine, but it is OK! I couldn't find anything about generating MO files for Windows
in the documentation.

Thanks,
Halley

____________________________________________________
Yahoo! Mail, cada vez melhor: agora com 1GB de espaço grátis! http://mail.yahoo.com.br

---

From: Euler Taveira de Oliveira <[email-masked]>
Date: Fri, 10 Jun 2005 14:14:46 -0300 (ART)

Hi Halley,

> generating MO files for Windows
The documentation don't talk about tools to handle it. Maybe a patch?
The poedit (www.poedit.org) is used to do the job on Windows.

PS> We need to talk in private about pt_BR docs

Euler Taveira de Oliveira
euler[at]yahoo_com_br

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 10 Jun 2005 19:27:53 +0200

Halley Pacheco de Oliveira wrote:
> It is working fine, but it is OK! I couldn't find anything about
> generating MO files for Windows in the documentation.

The MO files are generated automatically by the build process if you 
configured with --enable-nls.  I don't think it matters whether Windows 
is involved, as the gettext tools are evidently available there.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/