Subject: buffer freelist

From: Halley Pacheco de Oliveira <[email-masked]>
Date: Thu, 7 Jul 2005 07:29:33 -0300 (ART)

PostgreSQL 8.0.3 Documentation
Chapter 16. Server Run-time Environment
16.4. Run-time Configuration

debug_shared_buffers (integer)

Number of seconds between buffer freelist reports. If set greater than zero, emit freelist
statistics to the log every so many seconds. Zero (the default) disables reporting. 

What is a buffer freelist? I can't find a definition, and I can't translate if I don't understand.

Is it a list of free buffers as it seems to be? What is a free buffer?

Thanks,
Halley

__________________________________________________
Converse com seus amigos em tempo real com o Yahoo! Messenger 
http://br.download.yahoo.com/messenger/

---

From: Alvaro Herrera <[email-masked]>
Date: Thu, 7 Jul 2005 11:05:43 -0400

On Thu, Jul 07, 2005 at 07:29:33AM -0300, Halley Pacheco de Oliveira wrote:
> Number of seconds between buffer freelist reports. If set greater than
> zero, emit freelist statistics to the log every so many seconds. Zero
> (the default) disables reporting. 
> 

Yes, a list of free buffers.  A free buffer is a buffer that's not used
:-)  This is mainly a debugging option -- I don't think it would have
much use for regular users.  Then again, you may want to know how well
is your shared_buffers setting defined -- if too low, then freelists
will be short.

I doubt this can really be used to improve performance.

Note that this option disappeared in current in-development code ...

-- 
Alvaro Herrera (<alvherre[a]alvh.no-ip.org>)
"La realidad se compone de muchos sueños, todos ellos diferentes,
pero en cierto aspecto, parecidos..." (Yo, hablando de sueños eróticos)