Subject: mark wath catalogs are shared - was:(Re: [NOVICE] which database to login to to create global users?)

From: Jaime Casanova <[email-masked]>
Date: Wed, 4 Jan 2006 09:45:10 -0500

On 1/3/06, pres <[email-masked]> wrote:
> hello tom,
>
>
> > See also the documentation on the system catalogs:
> > http://www.postgresql.org/docs/8.1/static/catalogs.html
> > The description of each catalog takes care to mention it if the catalog
> > is shared across databases.
> >
> >                         regards, tom lane
> >
>
>
> i'm not yet sure if/where we can make enduser requests, but in reading the
> documentation's "System Catalogs" section you'd pointed me to, i, of course,
> find:
>
>
>
> "... A few catalogs are physically shared across all databases in a cluster;
> these are noted in the descriptions of the individual catalogs.
>
> Table 42-1. System Catalogs..."
>
> i would find it helpful if Table 42-1 included a column that identified
> whehter each catalog is shared or not.  convenient, but given that the
> documentation does contain it, not necessary.
>
> simply, it would be nice to see it as an overview.
>
> thank you again.
>
> pres

is this acceptable or usefull? if so, i can do it after work...

--
regards,
Jaime Casanova
(DBA: DataBase Aniquilator ;)

---

From: Tom Lane <[email-masked]>
Date: Wed, 04 Jan 2006 10:46:14 -0500

> is this acceptable or usefull? if so, i can do it after work...

It seems like clutter to me.  Whether a catalog is shared or not is not
necessarily the first thing you want to know about it.

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 4 Jan 2006 11:08:23 -0500 (EST)

> necessarily the first thing you want to know about it.

I am thinking the table should be split into two, one for the global
tables, and another for the db-local tables.  I don't think we make it
clear enough which tables are global.

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: Tom Lane <[email-masked]>
Date: Wed, 04 Jan 2006 11:16:15 -0500

> tables, and another for the db-local tables.

That's even worse, as it converts the distinction into something you
must know even to look up the table.

> I don't think we make it clear enough which tables are global.

I think the labels appearing in the per-catalog descriptions are plenty
clear.

			regards, tom lane