Subject: Patch for information_schema sgml file

From: Guillaume LELARGE <[email-masked]>
Date: Tue, 17 Jan 2006 23:38:30 +0100

Hi,

You'll find attached a patch for a fixed explanation on parameter_mode
column.

Regards.

-- 
Guillaume.
<!-- http://abs.traduc.org/
     http://lfs.traduc.org/
     http://traduc.postgresqlfr.org/ -->
Index: doc/src/sgml/information_schema.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/information_schema.sgml,v
retrieving revision 1.23
diff -u -3 -p -c -r1.23 information_schema.sgml
*** doc/src/sgml/information_schema.sgml	8 Dec 2005 20:48:10 -0000	1.23
--- doc/src/sgml/information_schema.sgml	17 Jan 2006 22:35:43 -0000
*************** ORDER BY c.ordinal_position;
*** 1875,1882 ****
        <entry><literal>parameter_mode</literal></entry>
        <entry><type>character_data</type></entry>
        <entry>
!        Always <literal>IN</literal>, meaning input parameter (in the
!        future there might be other parameter modes)
        </entry>
       </row>
  
--- 1875,1883 ----
        <entry><literal>parameter_mode</literal></entry>
        <entry><type>character_data</type></entry>
        <entry>
!        <literal>IN</literal> for input parameter,
!        <literal>OUT</literal> for output parameter,
!        and <literal>INOUT</literal> for input/ouput parameter.
        </entry>
       </row>

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 18 Jan 2006 16:03:03 -0500 (EST)

Patch applied.  Thanks.  Your documentation changes can be viewed in
five minutes using links on the developer's page,
http://www.postgresql.org/developer/testing.

---------------------------------------------------------------------------

> 
> ---------------------------(end of broadcast)---------------------------
> TIP 3: Have you checked our extensive FAQ?
> 
>                http://www.postgresql.org/docs/faq

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: Guillaume LELARGE <[email-masked]>
Date: Wed, 18 Jan 2006 23:03:13 +0100

> http://www.postgresql.org/developer/testing.

Great, thanks.

Did you apply it to the 8.1 branch as well ? because I think it should
be done. In fact, this is where I first saw this mistake and I've fixed
it too in the 8.1 french translated manual.

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 18 Jan 2006 17:25:29 -0500 (EST)

Guillaume LELARGE wrote:
> Bruce Momjian a ?crit :

Oops, forgot to do that.  Done.