Subject: Predicate Locking

From: David Fetter <[email-masked]>
Date: Fri, 1 Sep 2006 10:30:55 -0700

Folks,

This patch clarifies the 'predicate locking' section in the docs.
Thanks to Harrison Fisk of MySQL AB for helping.

Cheers,
D
-- 
David Fetter <[email-masked]> http://fetter.org/
phone: +1 415 235 3778        AIM: dfetter666
                              Skype: davidfetter

Remember to vote!
Index: doc/src/sgml/mvcc.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/mvcc.sgml,v
retrieving revision 2.57
diff -c -r2.57 mvcc.sgml
*** doc/src/sgml/mvcc.sgml	25 Aug 2006 04:06:45 -0000	2.57
--- doc/src/sgml/mvcc.sgml	1 Sep 2006 17:28:28 -0000
***************
*** 471,477 ****
      result in problems.  (Certainly the example above is rather contrived
      and unlikely to represent real software.)  Accordingly,
      <productname>PostgreSQL</productname> does not implement predicate
!     locking, and so far as we are aware no other production DBMS does either.
     </para>
  
     <para>
--- 471,480 ----
      result in problems.  (Certainly the example above is rather contrived
      and unlikely to represent real software.)  Accordingly,
      <productname>PostgreSQL</productname> does not implement predicate
!     locking.  No system based on next-key locking implements it
!     either because next-key locking only helps when all your
!     predicates are point or range searches against an available
!     B-tree index.  DB2, however, does implement predicate locking.
     </para>
  
     <para>

---

From: Peter Eisentraut <[email-masked]>
Date: Sat, 2 Sep 2006 00:31:57 +0200

> This patch clarifies the 'predicate locking' section in the docs.

What it does it raise the question what "next-key locking is".

I don't think any of this matters for us.  We should just remove the 
part that claims that no other system implements predicate locking.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 2 Sep 2006 21:58:52 -0400 (EDT)

> part that claims that no other system implements predicate locking.

OK, new text is:

     For these reasons,
    locking.

-- 
  Bruce Momjian   [email-masked]
  EnterpriseDB    http://www.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +