Subject: Broken link in PG docs

From: "Gurjeet Singh" <[email-masked]>
Date: Mon, 25 Sep 2006 16:44:47 +0530

At the end of the following page:

http://www.postgresql.org/docs/8.0/static/indexes-partial.html

 there is a link [Generalized Partial
Indexes<http://simon.cs.cornell.edu/home/praveen/papers/partindex.de95.ps.Z>]
which is pointing to a missing link.

    Can someone update the link with a live doc? Probably
 this one
<http://citeseer.ist.psu.edu/rd/0%252C67014%252C1%252C0.25%252CDownload/http://citeseer.ist.psu.edu/cache/papers/cs/1722/http:zSzzSzsimon.cs.cornell.eduzSzhomezSzpraveenzSzpaperszSzpartindex.de95.pdf/seshadri95generalized.pdf>

Regards,

-- 
[email-masked]
singh.gurjeet@{ gmail | hotmail | yahoo }.com

---

From: Neil Conway <[email-masked]>
Date: Mon, 25 Sep 2006 14:50:21 -0400

On Mon, 2006-09-25 at 16:44 +0530, Gurjeet Singh wrote:
>  there is a link [Generalized Partial Indexes] which is pointing to a
> missing link.

I agree the link should be fixed, but I can't see another canonical
location for the document online: linking to CiteSeer (which itself is
generated from the mention in our online docs) is probably not wise.

Can anyone find a good URL for this paper?

-Neil

---

From: "Jim C. Nasby" <[email-masked]>
Date: Mon, 25 Sep 2006 14:39:07 -0500

Moving to -docs

> <http://citeseer.ist.psu.edu/rd/0%252C67014%252C1%252C0.25%252CDownload/http://citeseer.ist.psu.edu/cache/papers/cs/1722/http:zSzzSzsimon.cs.cornell.eduzSzhomezSzpraveenzSzpaperszSzpartindex.de95.p…

Hrm... is there any means to update the docs for older versions outside
of a new release?

Even if the answer is 'no', it'd still be good to make the change in
CVS. See attached (btw, this is in the docs back to at least 7.2).
-- 
Jim Nasby                                            [email-masked]
EnterpriseDB      http://enterprisedb.com      512.569.9461 (cell)
Index: doc/src/sgml/biblio.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/biblio.sgml,v
retrieving revision 1.25
diff -c -r1.25 biblio.sgml
*** doc/src/sgml/biblio.sgml	16 Sep 2006 00:30:11 -0000	1.25
--- doc/src/sgml/biblio.sgml	25 Sep 2006 19:38:00 -0000
***************
*** 326,332 ****
  
     <biblioentry id="SESHADRI95">
     <biblioset relation="article">
!     <title><ulink url="http://simon.cs.cornell.edu/home/praveen/papers/partindex.de95.ps.Z">
      Generalized Partial Indexes
      </ulink>
      </title>
--- 326,332 ----
  
     <biblioentry id="SESHADRI95">
     <biblioset relation="article">
!     <title><ulink url="http://citeseer.ist.psu.edu/rd/0%252C67014%252C1%252C0.25%252CDownload/http://citeseer.ist.psu.edu/cache/papers/cs/1722/http:zSzzSzsimon.cs.cornell.eduzSzhomezSzpraveenzSzpaperszSzpartindex.de95.pdf/seshadri95generalized.pdf">
      Generalized Partial Indexes
      </ulink>
      </title>

---

From: Tom Lane <[email-masked]>
Date: Mon, 25 Sep 2006 19:09:16 -0400

> generated from the mention in our online docs) is probably not wise.

citeseer's cache still has the paper, and in it I find the authors'
email addresses ... could try writing to them ...

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 2 Oct 2006 18:29:31 -0400 (EDT)

I added the citeseer URL as an SGML comment.  Neil is trying to contact
the author.

---------------------------------------------------------------------------

Tom Lane wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 9: In versions below 8.0, the planner will ignore your desire to
>        choose an index scan if your joining column's datatypes do not
>        match

-- 
  Bruce Momjian   [email-masked]
  EnterpriseDB    http://www.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +