Subject: Texinfo docs/target

From: Andreas Seltenreich <[email-masked]>
Date: Sat, 19 Nov 2005 22:41:34 +0100

I've been using a texinfo (more precisely: info) version of the docs
for some weeks now, and really came to love it. It is still the
version I mentioned here:
<http://archives.postgresql.org/pgsql-general/2005-10/msg01813.php>

Now I'm wondering, if it'd be worth fixing the index and some minor
encoding deficiencies (e.g. medium-length dashes end up as "[mdash]"),
and adding Autoconf support in order to make it a proper target.

I remember other requests for info-docs on the lists than the above,
but it is rather hard to search for them :-/.

regards,
Andreas
--

---

From: Peter Eisentraut <[email-masked]>
Date: Sat, 19 Nov 2005 23:07:48 +0100

Andreas Seltenreich wrote:
> encoding deficiencies (e.g. medium-length dashes end up as
> "[mdash]"), and adding Autoconf support in order to make it a proper
> target.

We probably won't ship it with the default distribution, but I don't see 
any harm in at least providing build support for it initially.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

---

From: Andreas Seltenreich <[email-masked]>
Date: Fri, 29 Sep 2006 06:32:27 +0200

> any harm in at least providing build support for it initially.

The index seems to work with more recent versions of DB2X, and the
apparent encoding problems turned out to be an overlook in the
postgres.xml target.

I had to run makeinfo with the --no-validate option, mostly because
the info design doesn't allow duplicate node names.  However, it
doesn't seem to impair navigation besides addressing nodes by name,
and since most of the duplicate names are nodes like "Changes" in the
release notes section, I don't think it will be more of a nuisance
than being unable to look up Pi in the index...

I figured adding autoconf support for db2x/info wouldn't be very wise
as long as the experimental postgres.xml target the new rules depend
on doesn't have any either.

Patch attached.

regards,
andreas

Index: doc/src/sgml/Makefile
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/Makefile,v
retrieving revision 1.76
diff -u -r1.76 Makefile
--- doc/src/sgml/Makefile	6 Apr 2006 18:54:36 -0000	1.76
+++ doc/src/sgml/Makefile	29 Sep 2006 04:27:59 -0000
@@ -212,7 +212,7 @@
 
 postgres.xml: postgres.sgml $(GENERATED_SGML)
 	$(OSX) -x lower $< | \
-	  sed -e 's/\[\(lt\|gt\|amp\|nbsp\|copy\|quot\|ouml\|uuml\|egrave\) *\]/\&\1;/g' \
+	  sed -e 's/\[\(amp\|copy\|egrave\|gt\|lt\|mdash\|nbsp\|ouml\|pi\|quot\|uuml\) *\]/\&\1;/g' \
 	      -e '1a\' -e '<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN" "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">' \
 	  >$@
 
@@ -222,6 +222,24 @@
 htmlhelp: stylesheet-hh.xsl postgres.xml
 	$(XSLTPROC) $(XSLTPROCFLAGS) --stringparam pg.version '$(VERSION)' $^
 
+##
+## Experimental Texinfo targets
+##
+
+DB2X_TEXIXML = db2x_texixml
+DB2X_XSLTPROC = db2x_xsltproc
+MAKEINFO = makeinfo
+
+postgres.texixml: postgres.xml
+	$(DB2X_XSLTPROC) -s texi $< -o $@
+
+postgres.texi: postgres.texixml
+	$(DB2X_TEXIXML) --encoding=iso-8859-1//TRANSLIT $< \
+			--to-stdout > $@
+
+postgres.info: postgres.texi
+	$(MAKEINFO) --enable-encoding --no-split \
+		    --no-validate $< -o $@
 
 ##
 ## Check
@@ -249,3 +267,5 @@
 	rm -f INSTALL HISTORY regress_README
 # XML
 	rm -f postgres.xml htmlhelp.hhp toc.hhc index.hhk
+# Texinfo
+	rm -f *.texixml *.texi *.info db2texi.refs

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 2 Oct 2006 20:43:46 -0400 (EDT)

Your patch has been added to the PostgreSQL unapplied patches list at:

	http://momjian.postgresql.org/cgi-bin/pgpatches

It will be applied as soon as one of the PostgreSQL committers reviews
and approves it.

---------------------------------------------------------------------------

> 
> ---------------------------(end of broadcast)---------------------------
> TIP 4: Have you searched our list archives?
> 
>                http://archives.postgresql.org

-- 
  Bruce Momjian   [email-masked]
  EnterpriseDB    http://www.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 3 Oct 2006 17:13:24 -0400 (EDT)

Patch applied.  Thanks.

---

From: Andreas Seltenreich <[email-masked]>
Date: Thu, 05 Oct 2006 02:53:17 +0200

> Patch applied.  Thanks.

Here's a small update to pass the basename of the target as a
stylesheet parameter.  This makes the resulting info file work
properly when compressed or split.  It also prevents Debian's
"install-info" script from choking.

Thanks,
andreas

Index: doc/src/sgml/Makefile
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/Makefile,v
retrieving revision 1.77
diff -u -r1.77 Makefile
--- doc/src/sgml/Makefile	3 Oct 2006 21:13:17 -0000	1.77
+++ doc/src/sgml/Makefile	5 Oct 2006 00:32:33 -0000
@@ -231,7 +231,7 @@
 MAKEINFO = makeinfo
 
 postgres.texixml: postgres.xml
-	$(DB2X_XSLTPROC) -s texi $< -o $@
+	$(DB2X_XSLTPROC) -s texi -g output-file=$(basename $@) $< -o $@
 
 postgres.texi: postgres.texixml
 	$(DB2X_TEXIXML) --encoding=iso-8859-1//TRANSLIT $< \

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 4 Oct 2006 22:04:41 -0400 (EDT)

> "install-info" script from choking.

Applied.  Thanks.