Subject: Dtrace docs for core docs?

From: Josh Berkus <[email-masked]>
Date: Fri, 13 Oct 2006 17:10:17 -0700

All,

I'm thinking that some amount of DTrace documentation ought to go into the 
main docs.  I'm just not sure how much.

For reference, I have Robert's intro:
http://pgfoundry.org/docman/view.php/1000163/230/PostgreSQL-DTrace-Users-Guide.pdf

Plus several sample DScripts. 

I'm not sure how much I should be writing up for the main docs and how much 
keeping on the DTrace project page.  Help?

-- 
--Josh

Josh Berkus
PostgreSQL @ Sun
San Francisco

---

From: Peter Eisentraut <[email-masked]>
Date: Sat, 14 Oct 2006 02:32:23 +0200

Josh Berkus wrote:
> I'm thinking that some amount of DTrace documentation ought to go
> into the main docs.  I'm just not sure how much.

I think pretty much all of it.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

---

From: Josh Berkus <[email-masked]>
Date: Mon, 16 Oct 2006 14:50:15 -0700

Peter,

> I think pretty much all of it.

Ok, will work on formatting it.  I'll try to make it more about DTrace as 
an example of the GMF than anything else.

BTW, is the Dtrace build docs straightened out, or do I still need to patch 
it?  i.e. does it acurrately reflect that you need Solaris 10 update3 or 
OpenSolaris to build, currently?

-- 
--Josh

Josh Berkus
PostgreSQL @ Sun
San Francisco