Subject: Re: [PATCHES] [PERFORM] Direct I/O issues

From: Greg Smith <[email-masked]>
Date: Sat, 25 Nov 2006 04:34:52 -0500 (EST)

On Fri, 24 Nov 2006, Bruce Momjian wrote:

> OK, I modified test_fsync.c by copying the defines from xlog.c, and
> fixed the O_DIRECT alignment and check write()/fsync().

I just tested your new test_fsync as included in the 8.2rc1, and it's 
working perfectly for me now on Linux.  All the O_SYNC writes using 
O_DIRECT are reporting realistic timings.  I'm happy that this code is 
working as it should and appreciate the quick response.  I still think the 
wal_sync_method documentation deserves an update noting that O_DIRECT is 
used when available with the sync write methods.

--
* Greg Smith [email-masked] http://www.gregsmith.com Baltimore, MD

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 7 Feb 2007 22:57:22 -0500 (EST)

> used when available with the sync write methods.

O_DIRECT mention added, and backpatched to 8.2.X.

-- 
  Bruce Momjian  <[email-masked]>          http://momjian.us
  EnterpriseDB                               http://www.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +
Index: doc/src/sgml/config.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/config.sgml,v
retrieving revision 1.108
diff -c -c -r1.108 config.sgml
*** doc/src/sgml/config.sgml	1 Feb 2007 00:28:16 -0000	1.108
--- doc/src/sgml/config.sgml	8 Feb 2007 03:52:01 -0000
***************
*** 1385,1390 ****
--- 1385,1391 ----
          Not all of these choices are available on all platforms.
          The default is the first method in the above list that is supported
          by the platform.
+         The <literal>open_</>* options also use <literal>O_DIRECT</> if available.
          This parameter can only be set in the <filename>postgresql.conf</>
          file or on the server command line.
         </para>