Subject: doc patch for Linux memory overcommit

From: Toru SHIMOGAKI <[email-masked]>
Date: Tue, 06 Mar 2007 17:28:20 +0900

The attached is a doc patch for Linux memory overcommit and an additional way of
avoiding a problem that postmaster is suddenly killed by OOM-Killer.

http://archives.postgresql.org/pgsql-docs/2007-03/msg00000.php

Best regards,

-- 
Toru SHIMOGAKI<[email-masked]>
*** runtime.sgml.orig	2007-03-06 16:23:10.000000000 +0900
--- runtime.sgml	2007-03-06 17:14:38.000000000 +0900
***************
*** 1207,1215 ****
     </para>
  
     <para>
!     On Linux 2.6 and later, a better solution is to modify the kernel's
!     behavior so that it will not <quote>overcommit</> memory.  This is
!     done by selecting strict overcommit mode via <command>sysctl</command>:
  <programlisting>
  sysctl -w vm.overcommit_memory=2
  </programlisting>
--- 1207,1224 ----
     </para>
  
     <para>
!     In addition, increasing swap area on OS can avoid the problem too.
!     Out-of-Memory-Killer(OOM-Killer) is invoked whenever physical memory and 
!     swap area are exhausted. Increasing swap area is easy to set and it 
!     doesn't have harmful influence.
!    </para>
! 
!    <para>
!     On Linux 2.6 and later, a better solution is to modify the kernel's 
!     behavior so that it will not <quote>overcommit</> memory.  Though this 
!     setting can't prevent OOM-Killer from invoking directly, we can expect 
!     healty memory allocation. This is done by selecting strict overcommit 
!     mode via <command>sysctl</command>:
  <programlisting>
  sysctl -w vm.overcommit_memory=2
  </programlisting>

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 6 Mar 2007 09:44:38 +0100

Toru SHIMOGAKI wrote:
> The attached is a doc patch for Linux memory overcommit and an
> additional way of avoiding a problem that postmaster is suddenly
> killed by OOM-Killer.

The text needs some articles.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 6 Mar 2007 10:58:11 +0100

> additional way of avoiding a problem that postmaster is suddenly

Patch installed.