Subject: patch for doubled words

From: Brian Gough <[email-masked]>
Date: Thu, 03 May 2007 15:32:33 +0100

Hello,

Here is a patch for some doubled words in the manual
(e.g. "the the").

I'm in the process of producing a printed version of
the documentation in book format.  If anyone from the
PostgreSQL team would like to see the proofs before
they go to press I'll be glad to make them available.

-- 
best regards,

Brian Gough

Network Theory Ltd,
Publishing Free Software Manuals --- http://www.network-theory.co.uk/

Index: doc/src/sgml/datatype.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/datatype.sgml,v
retrieving revision 1.198
diff -u -r1.198 datatype.sgml
--- doc/src/sgml/datatype.sgml	21 Apr 2007 17:26:17 -0000	1.198
+++ doc/src/sgml/datatype.sgml	3 May 2007 13:57:46 -0000
@@ -3376,7 +3376,7 @@
 
    <para>
     When using the binary mode to pass query parameters to the server
-    and query results back the the client, no character set conversion
+    and query results back to the client, no character set conversion
     is performed, so the situation is different.  In this case, an
     encoding declaration in the XML data will be observed, and if it
     is absent, the data will be assumed to be in UTF-8 (as required by
Index: doc/src/sgml/ddl.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/ddl.sgml,v
retrieving revision 1.73
diff -u -r1.73 ddl.sgml
--- doc/src/sgml/ddl.sgml	1 Feb 2007 00:28:16 -0000	1.73
+++ doc/src/sgml/ddl.sgml	3 May 2007 13:57:48 -0000
@@ -2233,7 +2233,7 @@
 
     <listitem>
      <para>
-      When queries or updates access a large percentage of a a single
+      When queries or updates access a large percentage of a single
       partition, performance can be improved by taking advantage
       of sequential scan of that partition instead of using an
       index and random access reads scattered across the whole table.
@@ -2556,7 +2556,7 @@
 </programlisting>
 
         Note that the <literal>WHERE</literal> clause in each rule
-        exactly matches the the <literal>CHECK</literal>
+        exactly matches the <literal>CHECK</literal>
         constraint for its partition.
        </para>
       </listitem>
Index: doc/src/sgml/plperl.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/plperl.sgml,v
retrieving revision 2.64
diff -u -r2.64 plperl.sgml
--- doc/src/sgml/plperl.sgml	16 Feb 2007 03:50:29 -0000	2.64
+++ doc/src/sgml/plperl.sgml	3 May 2007 13:57:52 -0000
@@ -20,7 +20,7 @@
   <para> The usual advantage to using PL/Perl is that this allows use,
    within stored functions, of the manyfold <quote>string
     munging</quote> operators and functions available for Perl.  Parsing
-   complex strings might be be easier using Perl than it is with the
+   complex strings might be easier using Perl than it is with the
    string functions and control structures provided in PL/pgSQL.</para>
   
   <para>
@@ -619,7 +619,7 @@
 $$ LANGUAGE plperl;
 </programlisting>
     The creation of this function will fail as its use of a forbidden
-    operation will be be caught by the validator.
+    operation will be caught by the validator.
   </para>
 
   <para>
Index: doc/src/sgml/spi.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/spi.sgml,v
retrieving revision 1.56
diff -u -r1.56 spi.sgml
--- doc/src/sgml/spi.sgml	16 Apr 2007 01:14:55 -0000	1.56
+++ doc/src/sgml/spi.sgml	3 May 2007 13:57:54 -0000
@@ -2233,7 +2233,7 @@
    Column value, or <symbol>NULL</symbol> if the column is null,
    <parameter>colnumber</parameter> is out of range
    (<varname>SPI_result</varname> is set to
-   <symbol>SPI_ERROR_NOATTRIBUTE</symbol>), or no no output function
+   <symbol>SPI_ERROR_NOATTRIBUTE</symbol>), or no output function is
    available (<varname>SPI_result</varname> is set to
    <symbol>SPI_ERROR_NOOUTFUNC</symbol>).
   </para>

---

From: Neil Conway <[email-masked]>
Date: Thu, 03 May 2007 11:11:39 -0400

> Here is a patch for some doubled words in the manual

Applied, thanks for the patch.

-Neil

---

From: Alvaro Herrera <[email-masked]>
Date: Thu, 3 May 2007 11:19:58 -0400

> Applied, thanks for the patch.

There are a few more in this patch.

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
The PostgreSQL Company - Command Prompt, Inc.
Index: doc/src/sgml/external-projects.sgml
===================================================================
RCS file: /home/alvherre/Code/cvs/pgsql/doc/src/sgml/external-projects.sgml,v
retrieving revision 1.15
diff -c -p -r1.15 external-projects.sgml
*** doc/src/sgml/external-projects.sgml	31 Jan 2007 20:56:17 -0000	1.15
--- doc/src/sgml/external-projects.sgml	3 May 2007 14:56:16 -0000
***************
*** 31,37 ****
      currently closed to new projects in favor of PgFoundry, it still
      contains many active and relevant projects. Other popular
      <productname>PostgreSQL</productname>-related projects are hosted
!     independently, or on other project-hosting sites such such as <ulink
      url="http://sourceforge.net/">SourceForge.net</ulink>. You should search
      the web if you don't find the project you are looking for.
     </para>
--- 31,37 ----
      currently closed to new projects in favor of PgFoundry, it still
      contains many active and relevant projects. Other popular
      <productname>PostgreSQL</productname>-related projects are hosted
!     independently, or on other project-hosting sites such as <ulink
      url="http://sourceforge.net/">SourceForge.net</ulink>. You should search
      the web if you don't find the project you are looking for.
     </para>
Index: doc/src/sgml/maintenance.sgml
===================================================================
RCS file: /home/alvherre/Code/cvs/pgsql/doc/src/sgml/maintenance.sgml,v
retrieving revision 1.72
diff -c -p -r1.72 maintenance.sgml
*** doc/src/sgml/maintenance.sgml	18 Apr 2007 20:44:53 -0000	1.72
--- doc/src/sgml/maintenance.sgml	3 May 2007 14:56:28 -0000
*************** HINT:  Stop the postmaster and use a sta
*** 490,496 ****
  
     <para>
      There is a limit of <xref linkend="guc-autovacuum-max-workers"> worker
!     processes that may be running at at any time, so if the <command>VACUUM</>
      and <command>ANALYZE</> work to do takes too long to run, the deadline may
      be failed to meet for other databases.  Also, if a particular database
      takes long to process, more than one worker may be processing it
--- 490,496 ----
  
     <para>
      There is a limit of <xref linkend="guc-autovacuum-max-workers"> worker
!     processes that may be running at any time, so if the <command>VACUUM</>
      and <command>ANALYZE</> work to do takes too long to run, the deadline may
      be failed to meet for other databases.  Also, if a particular database
      takes long to process, more than one worker may be processing it
Index: doc/src/sgml/release.sgml
===================================================================
RCS file: /home/alvherre/Code/cvs/pgsql/doc/src/sgml/release.sgml,v
retrieving revision 1.502
diff -c -p -r1.502 release.sgml
*** doc/src/sgml/release.sgml	20 Apr 2007 03:27:23 -0000	1.502
--- doc/src/sgml/release.sgml	3 May 2007 14:57:16 -0000
*************** Fix for SELECT timespan('21:11:26'::time
*** 16463,16469 ****
  netmask('x.x.x.x/0') is 255.255.255.255 instead of 0.0.0.0 (Oleg Sharoiko)
  Add btree index on NUMERIC (Jan)
  Perl fix for large objects containing NUL characters (Douglas Thomson)
! ODBC fix for for large objects (free)
  Fix indexing of cidr data type
  Fix for Ethernet MAC addresses (macaddr type) comparisons
  Fix for date/time types when overflows happened in computations (Tom)
--- 16463,16469 ----
  netmask('x.x.x.x/0') is 255.255.255.255 instead of 0.0.0.0 (Oleg Sharoiko)
  Add btree index on NUMERIC (Jan)
  Perl fix for large objects containing NUL characters (Douglas Thomson)
! ODBC fix for large objects (free)
  Fix indexing of cidr data type
  Fix for Ethernet MAC addresses (macaddr type) comparisons
  Fix for date/time types when overflows happened in computations (Tom)
*************** more compliant to the SQL-92 standard):
*** 19056,19062 ****
  
          "WITH GRANT OPTION" is not supported.  Only class owners can change
          access control
!    - The default access control is to to grant users readonly access.
       You must explicitly grant insert/update access to users.  To change
       this, modify the line in
                  src/backend/utils/acl.h
--- 19056,19062 ----
  
          "WITH GRANT OPTION" is not supported.  Only class owners can change
          access control
!    - The default access control is to grant users readonly access.
       You must explicitly grant insert/update access to users.  To change
       this, modify the line in
                  src/backend/utils/acl.h
Index: doc/src/sgml/ref/psql-ref.sgml
===================================================================
RCS file: /home/alvherre/Code/cvs/pgsql/doc/src/sgml/ref/psql-ref.sgml,v
retrieving revision 1.190
diff -c -p -r1.190 psql-ref.sgml
*** doc/src/sgml/ref/psql-ref.sgml	26 Mar 2007 17:23:37 -0000	1.190
--- doc/src/sgml/ref/psql-ref.sgml	3 May 2007 14:58:13 -0000
*************** PostgreSQL documentation
*** 114,120 ****
         argument on the command line.
        </para>
        <para>
!        If this parameter contains an <symbol>=</symbol> sign, it it treated as a
         <parameter>conninfo</parameter> string. See <xref linkend="libpq-connect"> for more information.
        </para>
        </listitem>
--- 114,120 ----
         argument on the command line.
        </para>
        <para>
!        If this parameter contains an <symbol>=</symbol> sign, it is treated as a
         <parameter>conninfo</parameter> string. See <xref linkend="libpq-connect"> for more information.
        </para>
        </listitem>