Subject: Re: Full Text Search examples patch

From: "Erik" <[email-masked]>
Date: Wed, 16 Jan 2008 03:06:37 +0100 (CET)

Alvaro Herrera wrote:
> Erik wrote:
>> Tom Lane wrote:
>> > "Erik" <[email-masked]> writes:
>> >> I changed all references to 'pgweb' to 'apod'. This
>> apod
>> >> table initially corresponds with the structure of the
>> >> table in the dump file.  (In the documentation, that
>> >> table
>> >> is subsequently changed by adding a tsvector column.)
>> >
>> > Huh?  These are just examples, they are not supposed
>> to
>> > refer to any
>> > specific real table, much less one that comes standard
>> > with Postgres.
>>
>> I understand that, of course.  I am suggesting it might
>> be
>> an improvement to offer the data to go with the
>> examples.
>
> Hmm, wouldn't it be easier to provide the pgweb table?

Maybe - I don't know what that pgweb data would be.

There are really two issues:

  1. Apply changes I suggested (and attached earlier) to
the documentation text to make code examples use a
single table instead of two different ones.  I chose
apod because I knew apod from tsearch2.  In the patch
there are also some confusing inconsistencies removed,
for instance column  'textsearch_indexable_col' is in a
later code example used as column 'textsearch'.

  2. Whether or not to include some actual table data (be
it apod or pgweb). This is less important as far as I am
concerned.

 The first is more useful and easier to apply than the
second.

> Alvaro Herrera
> http://www.CommandPrompt.com/
> PostgreSQL Replication, Consulting, Custom Development,
> 24x7 support
>
> ---------------------------(end of
> broadcast)---------------------------
> TIP 7: You can help support the PostgreSQL project by
> donating at
>
>                 http://www.postgresql.org/about/donate
>

regards,

Erik Rijkers

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 26 Mar 2008 10:10:27 -0400 (EDT)

>  The first is more useful and easier to apply than the

Agreed.  The data file you sent was 1.5MB of data uncompressed.  That
isn't going in the docs.

I looked at adding just the schema you had:

	CREATE TABLE apod (
	    title text,
	    body text,
	    sdate date,
	    keywords text,
	    id integer
	);

but later saw that there were 'apod' references later in the docs that
mentioned columns that weren't in the CREATE TABLE, e.g., 'vector':

	SELECT * FROM ts_stat('SELECT vector FROM apod')
	ORDER BY nentry DESC, ndoc DESC, word
	LIMIT 10;

Please send a patch that adds the CREATE TABLE in a consistent manner
and we will consider just that addition.  Here is where I suggest you
add the CREATE TABLE in the patch:

	<programlisting>
	CREATE TABLE apod (
	    title      text,
	    body       text,
	    sdate      date,
	    keywords   text,
	    id         integer);
	
	-- insert some data
	
	SELECT title, ts_rank_cd(textsearch, query) AS rank
	FROM apod, to_tsquery('neutrino|(dark &amp; matter)') query
	WHERE query @@ textsearch
	ORDER BY rank DESC LIMIT 10;

I am fine with you updating the later examples to be more consistent
too.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://postgres.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +