Subject: Update to FAQ

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 8 Apr 2008 17:18:11 -0700

To address naming issue.

-- 
The PostgreSQL Company since 1997: http://www.commandprompt.com/ 
PostgreSQL Community Conference: http://www.postgresqlconference.org/
United States PostgreSQL Association: http://www.postgresql.us/
Donate to the PostgreSQL Project: http://www.postgresql.org/about/donate

Index: FAQ
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/FAQ,v
retrieving revision 1.452
diff -c -r1.452 FAQ
*** FAQ	3 Mar 2008 16:22:55 -0000	1.452
--- FAQ	9 Apr 2008 00:13:38 -0000
***************
*** 105,114 ****
     company. To get involved, see the developer's FAQ at
     http://www.postgresql.org/docs/faqs.FAQ_DEV.html
     
!    Postgres is a widely-used nickname for PostgreSQL. It was the original
!    name of the project at Berkeley and is strongly preferred over other
!    nicknames. If you find 'PostgreSQL' hard to pronounce, call it
!    'Postgres' instead.
     
    1.2) Who controls PostgreSQL?
    
--- 105,118 ----
     company. To get involved, see the developer's FAQ at
     http://www.postgresql.org/docs/faqs.FAQ_DEV.html
     
!    In November 2007 a classic Open Source debate took place on whether
!    or not to change the name of the PostgreSQL project to Postgres.
!    It was decided that Postgres would be an officially recognized 
!    nickname but that the name would remain PostgreSQL. Postgres was 
!    the original name of the project at Berkeley and is strongly 
!    preferred over other nicknames. If you find 'PostgreSQL' hard 
!    to pronounce, call it 'Postgres' instead.
!    
     
    1.2) Who controls PostgreSQL?

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 8 Apr 2008 20:35:40 -0400 (EDT)

I don't see the value in referencing a community discussion in the FAQ. 
What is the goal for this change?

---------------------------------------------------------------------------

> To address naming issue.

[ Attachment, skipping... ]

> 
> -- 
> Sent via pgsql-docs mailing list ([email-masked])
> To make changes to your subscription:
> http://www.postgresql.org/mailpref/pgsql-docs

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Wed, 9 Apr 2008 00:42:07 -0000

Joshua proposed:

The debate has certainly spread well before (and after) November 2007.
Not sure what makes it a "classic Open Source debate" either. Because
it was debated in the open? I think the "decision" was basically
Core's punting of making the tough but necessary decision to make
the project name pronounceable once again (if I can add some spin
of my own :). If we are going to say "It was decided", we need
to state who (Core) actually did the decreeing / deciding.

In case it wasn't clear, I'm not in support of changing the FAQ
as proposed above.

- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200804082039
http://biglumber.com/x/web?pk=2529DF6AB8F79407E94445B4BC9B906714964AC8

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 8 Apr 2008 20:46:23 -0400 (EDT)

Greg Sabino Mullane wrote:
[ There is text before PGP section. ]
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: RIPEMD160
> 
> 
> Joshua proposed:
> 

In looking at it now I see the Berkeley sentence isn't necessary so I
just remove it.  (It was copied from the documentation.)  New text:

    <P>Postgres is a widely-used nickname for PostgreSQL.  If you find
    'PostgreSQL' hard to pronounce, call it 'Postgres' instead.</P>

Shorter is better in the FAQ.

---

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 8 Apr 2008 17:52:54 -0700

On Wed,  9 Apr 2008 00:42:07 -0000
"Greg Sabino Mullane" <[email-masked]> wrote:

> !    In November 2007 a classic Open Source debate took place on
> whether !    or not to change the name of the PostgreSQL project to
> Postgres. !    It was decided that Postgres would be an officially
> recognized !    nickname but that the name would remain PostgreSQL.
> Postgres was !    the original name of the project at Berkeley and is
> strongly !    preferred over other nicknames. If you find
> 'PostgreSQL' hard !    to pronounce, call it 'Postgres' instead.
> !
> 

The "decision" came down from core in 11/2007 which is why I referenced
it.

> Not sure what makes it a "classic Open Source debate" either.

Long winded, full of flames and pointless :P

> Because

Dave Page:

http://archives.postgresql.org/pgsql-advocacy/2007-11/msg00109.php

Sincerely,

Joshua D. Drake