Subject: pl/PgSQL, variable names in NEW

From: Martin Edlman <[email-masked]>
Date: Mon, 07 Apr 2008 13:19:39 +0200

Hello,

	is it possible to use variables as field names in the NEW record? Let's 
suppose I have a varchar attname containg the name of the field and I want 
to know a value that field of the NEW record.

Problem is that I get an error 'record "new" has no field "attname"'. Of 
course I want to use a value of NEW.author when col.attname = attname = 
'author'.

Is there a solution?

Example trigger function. It finds all columns in the table which are 
referenced in other tables and checks if the value of the column has 
changed. If yes, then invoke some other function. The problem is that the 
column name is in the 'col' record and is different during the loop and at 
each function call.

CREATE OR REPLACE FUNCTION replace_values() RETURNS trigger AS
$BODY$
	DECLARE
		col record;
		attname varchar;
	BEGIN
		FOR col IN
		SELECT DISTINCT pgaf.attname, pgaf.attnum
		FROM pg_constraint, pg_attribute AS pgaf
		WHERE pg_constraint.contype = 'f'	-- fkey
		AND pg_constraint.confrelid = TG_RELID	-- table oid
		AND pgaf.attrelid = TG_RELID
		AND pgaf.attnum = ANY(pg_constraint.confkey) LOOP

			attname := col.attname;
			IF NEW.attname <> OLD.attname THEN
				RAISE NOTICE '  value changed from "%" to "%"', OLD.attname, NEW.attname;
				-- INVOKE OTHER FUNCTION
			END IF;
		END LOOP;

	END;
$BODY$
   LANGUAGE 'plpgsql' VOLATILE;

-- 
Martin Edlman
Fortech Ltd.
57001 Litomysl, CZ

---

From: "Pavel Stehule" <[email-masked]>
Date: Mon, 7 Apr 2008 14:11:23 +0200

Hello

no, it's not possible in plpgsql. Please, use plperl or plpython.

Regards
Pavel Stehule

On 07/04/2008, Martin Edlman <[email-masked]> wrote:
> Hello,
>
>         is it possible to use variables as field names in the NEW record?
> Let's suppose I have a varchar attname containg the name of the field and I
> want to know a value that field of the NEW record.
>
>  Sent via pgsql-sql mailing list ([email-masked])
>  To make changes to your subscription:
>  http://www.postgresql.org/mailpref/pgsql-sql
>

---

From: Martin Edlman <[email-masked]>
Date: Tue, 08 Apr 2008 13:06:47 +0200

Hello,

| no, it's not possible in plpgsql. Please, use plperl or plpython.

thanks for the response. It's as I expected and was afraid of :-(
I select data from DB using pl/PgSQL in the replace_values trigger and
then call plPerl function which returns value from NEW and OLD. The
problem is that as I need to pass NEW and OLD to the Perl function I get
error message "no function matching get_value(x_lokalita, name)" as NEW
and OLD are records of table x_lokalita.
My plPerl function is declared as get_value(record, name). Is it
possible to cast table record type "x_lokalita" to generic type
"record"? (NEW::record doesn't work!)
I call the trigger replace_values() on several tables so I don't know
the record type. Do I have to create get_value() for each table, eg.
get_value(x_lokalita, name)?

I don't want to rewrite whole trigger to plPerl as I would have to use
DBD-PgSPI.

CREATE OR REPLACE FUNCTION get_value(record, name) RETURNS character
varying AS $BODY$
	my($rec, $col) = @_;
	return $rec->{$col};
$BODY$ LANGUAGE 'plperl' VOLATILE;

CREATE OR REPLACE FUNCTION replace_values() RETURNS "trigger" AS $BODY$
	-- code with SQL queries
	-- ...
	newval := get_value(NEW, col.attname);
	oldval := get_value(OLD, col.attname);
	IF newval <> oldval THEN
		-- call other functions
	END IF;
	-- code
	RETURN NEW;
	END;
$BODY$ LANGUAGE 'plpgsql' VOLATILE;

| On 07/04/2008, Martin Edlman <[email-masked]> wrote:
|> Hello,
|>
|>         is it possible to use variables as field names in the NEW record?
|> Let's suppose I have a varchar attname containg the name of the field
and I
|> want to know a value that field of the NEW record.
|>
|>  Problem is that I get an error 'record "new" has no field "attname"'. Of
|> course I want to use a value of NEW.author when col.attname = attname =
|> 'author'.
|>
|>  Is there a solution?
|>
|>  Example trigger function. It finds all columns in the table which are
|> referenced in other tables and checks if the value of the column has
|> changed. If yes, then invoke some other function. The problem is that the
|> column name is in the 'col' record and is different during the loop
and at
|> each function call.
|>
|>  CREATE OR REPLACE FUNCTION replace_values() RETURNS trigger AS
|>  $BODY$
|>         DECLARE
|>                 col record;
|>                 attname varchar;
|>         BEGIN
|>                 FOR col IN
|>                 SELECT DISTINCT pgaf.attname, pgaf.attnum
|>                 FROM pg_constraint, pg_attribute AS pgaf
|>                 WHERE pg_constraint.contype = 'f'       -- fkey
|>                 AND pg_constraint.confrelid = TG_RELID  -- table oid
|>                 AND pgaf.attrelid = TG_RELID
|>                 AND pgaf.attnum = ANY(pg_constraint.confkey) LOOP
|>
|>                         attname := col.attname;
|>                         IF NEW.attname <> OLD.attname THEN
|>                                 RAISE NOTICE '  value changed from "%" to
|> "%"', OLD.attname, NEW.attname;
|>                                 -- INVOKE OTHER FUNCTION
|>                         END IF;
|>                 END LOOP;
|>
|>         END;
|>  $BODY$
|>   LANGUAGE 'plpgsql' VOLATILE;
|>
|>  --
|>  Martin Edlman
|>  Fortech Ltd.
|>  57001 Litomysl, CZ
|>
|>  --
|>  Sent via pgsql-sql mailing list ([email-masked])
|>  To make changes to your subscription:
|>  http://www.postgresql.org/mailpref/pgsql-sql
|>

- --
S pozdravem,

Martin Edlman
Fortech, spol. s r.o,
Ropkova 51, 57001 Litomyšl
Public GPG key: http://edas.visaci.cz/#gpgkeys

---

From: Alvaro Herrera <[email-masked]>
Date: Tue, 8 Apr 2008 09:21:57 -0400

> I don't want to rewrite whole trigger to plPerl as I would have to use

Huh?  Certainly not -- there are functions in PL/Perl for this.  See
spi_exec_query in
http://www.postgresql.org/docs/8.3/static/plperl-database.html

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
The PostgreSQL Company - Command Prompt, Inc.

---

From: Martin Edlman <[email-masked]>
Date: Thu, 10 Apr 2008 13:34:06 +0200

|> I don't want to rewrite whole trigger to plPerl as I would have to use
|> DBD-PgSPI.
|
| Huh?  Certainly not -- there are functions in PL/Perl for this.  See
| spi_exec_query in
| http://www.postgresql.org/docs/8.3/static/plperl-database.html

Oh, I see. I have read the doc "...can be done via the function
spi_exec_query described below, or via an experimental module
DBD::PgSPI...", but missed the "OR" and thought that DBD::PgSPI is
mandatory.
Thanks.

Martin

- --
Regards,

Martin Edlman
Fortech, spol. s r.o,

---

From: Alvaro Herrera <[email-masked]>
Date: Thu, 10 Apr 2008 09:16:02 -0400

> DBD::PgSPI...", but missed the "OR" and thought that DBD::PgSPI is

Yeah, that's a bit confusing.  I don't know why we have a mention of
DBD::PgSPI on the plperl manual at all.  Is there anything it can do
that can't be done with PL/Perl native calls?

Question for plperl hackers:  Should we remove the mention of DBD::PgSPI
from the PL/Perl manual?

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
PostgreSQL Replication, Consulting, Custom Development, 24x7 support

---

From: Tom Lane <[email-masked]>
Date: Thu, 10 Apr 2008 10:45:25 -0400

> Question for plperl hackers:  Should we remove the mention of DBD::PgSPI

It seems like a reasonable suggestion to me, since perl database users
probably already know DBD and don't have to learn something new if they
go that way.

Possibly the text should be reworded, with the mention of DBD::PgSPI put
somewhere else or stuck into a <note> or something.

			regards, tom lane

---

From: "Joshua D. Drake" <[email-masked]>
Date: Thu, 10 Apr 2008 07:51:09 -0700

On Thu, 10 Apr 2008 10:45:25 -0400
Tom Lane <[email-masked]> wrote:

> > Question for plperl hackers:  Should we remove the mention of
> > DBD::PgSPI from the PL/Perl manual?
> 
> probably already know DBD and don't have to learn something new if
> they go that way.
> 
> Possibly the text should be reworded, with the mention of DBD::PgSPI
> put somewhere else or stuck into a <note> or something.

From what I can see on CPAN (unless I am missing something) DBD::PgSPI
hasn't been updated since 2004 and is at version 0.2.

http://www.cpan.org/modules/by-module/DBD/

I think it can safely be removed in entirety from our manuals.

Sincerely,

Joshua D. Drake

-- 
The PostgreSQL Company since 1997: http://www.commandprompt.com/ 
PostgreSQL Community Conference: http://www.postgresqlconference.org/
United States PostgreSQL Association: http://www.postgresql.us/
Donate to the PostgreSQL Project: http://www.postgresql.org/about/donate

---

From: Andrew Dunstan <[email-masked]>
Date: Thu, 10 Apr 2008 10:56:31 -0400

> I think it can safely be removed in entirety from our manuals.

+1. It's also GNU licensed, so we can't include it. A clean room BSD 
licensed implementation would be a nice addition, but it really doesn't 
buy you much in functionality that you don't already have.

cheers

andrew

---

From: Tom Lane <[email-masked]>
Date: Thu, 10 Apr 2008 10:58:51 -0400

> hasn't been updated since 2004 and is at version 0.2.

Oh, if it's not a live project then that changes things entirely.
+1 for just dropping the mention.

			regards, tom lane

---

From: Alvaro Herrera <[email-masked]>
Date: Thu, 10 Apr 2008 11:21:06 -0400

> +1 for just dropping the mention.

Done.