Subject: TODO build rule

From: Peter Eisentraut <[email-masked]>
Date: Tue, 12 Aug 2008 13:00:17 +0300

I tried building TODO.html from TODO according to the description in
doc/src/FAQ/README, but saw the following kind of difference repeating:

@@ -24,7 +24,7 @@
 <h1><a name="section_2">Administration</a></h1>

 <ul>
-  <li>-<em>Allow administrators to safely terminate individual sessions either</em>
+  <li>-Allow administrators to safely terminate individual sessions either
   via an SQL function or SIGTERM
   </li><li>Check for unreferenced table files created by transactions that were
   in-progress when the server terminated abruptly

Apparently, there is a piece of code missing that adds these <em> tags around
the done items.  Bruce, do you have this code, and can you add it to the README?

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 15 Aug 2008 20:22:09 -0400 (EDT)

> doc/src/FAQ/README, but saw the following kind of difference repeating:

These two lines in pgsql/src/tools/TODO2html should be adding "*"s which
is then interpreted as "<em>":

	sed 's/^\(\* -\)\(.*\)$/\1*\2*/' |
	sed 's/^\([     ][      ]*o -\)\(.*\)$/\1*\2*/' |

Is there some 'sed' incompatibility there?

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +

---

From: Peter Eisentraut <[email-masked]>
Date: Sat, 16 Aug 2008 21:04:34 +0300

> > Apparently, there is a piece of code missing that adds these <em> tags
> > around the done items.  Bruce, do you have this code, and can you add it
> > to the README?
>

So there are two inconsistent sets of instructions for creating TODO.html, one 
in doc/src/FAQ/README and one in src/tools/TODO2html.  Which one is being 
used?

I want to convert the real one to a makefile, btw.

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 16 Aug 2008 15:39:59 -0400 (EDT)

> I want to convert the real one to a makefile, btw.

Oh, I forgot that README talked about making TODO.html.  I have updated
the README to suggest using pgsql/src/tools/TODO2html.

---

From: David Fetter <[email-masked]>
Date: Sun, 17 Aug 2008 10:54:30 -0700

On Sat, Aug 16, 2008 at 03:39:59PM -0400, Bruce Momjian wrote:
> > > These two lines in pgsql/src/tools/TODO2html should be adding
> > > "*"s which is then interpreted as "<em>":
> > 
> > So there are two inconsistent sets of instructions for creating
> > TODO.html, one in doc/src/FAQ/README and one in
> > src/tools/TODO2html.  Which one is being used?
> > 
> Oh, I forgot that README talked about making TODO.html.  I have
> updated the README to suggest using pgsql/src/tools/TODO2html.

I thought this was going onto the wiki so Bruce doesn't have to be the
sole maintainer :)

Cheers,
David.
-- 
David Fetter <[email-masked]> http://fetter.org/
Phone: +1 415 235 3778  AIM: dfetter666  Yahoo!: dfetter
Skype: davidfetter      XMPP: [email-masked]

Remember to vote!
Consider donating to Postgres: http://www.postgresql.org/about/donate

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 18 Aug 2008 10:31:44 -0400 (EDT)

> I thought this was going onto the wiki so Bruce doesn't have to be the

We have discussed the idea and Magnus did a wiki version for testing.  I
am not sure where are in moving that forward.  Anyone with CVS access
can modify it now and you can send in patches for it too.