Subject: Please add REINDEX note to 8.3.5 release notes.

From: Josh Berkus <[email-masked]>
Date: Wed, 05 Nov 2008 11:03:42 -0800

Folks,

In the Release Notes for 8.3.5, 8.2.11, and 8.1.15, no mention is made 
of the need to REINDEX GiST indexes for some users. Please add this 
sentence to each Migration to Version section.

Please update soon; people are being confused between the apparent 
contradiction between the Release Notes and the announcement.

-----------

E.1.1. Migration to Version 8.3.5

+ If you were previously running version 8.3.4, run REINDEX on all GiST 
indexes after upgrade.

-----------

E.7.1. Migration to Version 8.2.11

+ If you were previously running version 8.2.10, run REINDEX on all GiST 
indexes after upgrade.

-----------

E.19.1. Migration to Version 8.1.15

+ If you were previously running version 8.1.15, run REINDEX on all GiST 
indexes after upgrade.

----------

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 8 Jan 2009 20:48:17 -0500 (EST)

Done, with the attached patch applied to appropriate back branches.

---------------------------------------------------------------------------

Josh Berkus wrote:
> -- 
> Sent via pgsql-docs mailing list ([email-masked])
> To make changes to your subscription:
> http://www.postgresql.org/mailpref/pgsql-docs

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +
Index: release.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/release.sgml,v
retrieving revision 1.587
retrieving revision 1.588
diff -c -c -r1.587 -r1.588
*** release.sgml	30 Oct 2008 22:22:24 -0000	1.587
--- release.sgml	9 Jan 2009 01:47:02 -0000	1.588
***************
*** 1,4 ****
! <!-- $PostgreSQL: pgsql/doc/src/sgml/release.sgml,v 1.587 2008/10/30 22:22:24 tgl Exp $ -->
  <!--
  
  Typical markup:
--- 1,4 ----
! <!-- $PostgreSQL: pgsql/doc/src/sgml/release.sgml,v 1.588 2009/01/09 01:47:02 momjian Exp $ -->
  <!--
  
  Typical markup:
***************
*** 83,89 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see the release notes for 8.3.1.
     </para>
  
    </sect2>
--- 83,91 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see the release notes for 8.3.1.  If you were running a previous
!     8.3.X release, REINDEX all GiST indexes after the upgrade.
! 
     </para>
  
    </sect2>
***************
*** 4042,4048 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see the release notes for 8.2.7.
     </para>
  
    </sect2>
--- 4044,4051 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see the release notes for 8.2.7.  If you were running a previous
!     8.2.X release, REINDEX all GiST indexes after the upgrade.
     </para>
  
    </sect2>
***************
*** 8494,8500 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
    </sect2>
--- 8497,8504 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.  If you were running a previous
!     8.1.X release, REINDEX all GiST indexes after the upgrade.
     </para>
  
    </sect2>