Subject: Array functions not mentioned in Index

From: Mario Splivalo <[email-masked]>
Date: Sun, 29 Mar 2009 17:12:13 +0200

None of the array functions
(http://www.postgresql.org/docs/8.3/interactive/functions-array.html)
are mentioned in the documentation index. Is that intentional?
I thought it would be 'handy' to have those functions referenced in index.

	Mike

---

From: Alvaro Herrera <[email-masked]>
Date: Mon, 30 Mar 2009 11:47:30 -0400

> I thought it would be 'handy' to have those functions referenced in index.

Agreed -- please submit a patch.

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
PostgreSQL Replication, Consulting, Custom Development, 24x7 support

---

From: Mario Splivalo <[email-masked]>
Date: Tue, 31 Mar 2009 13:09:03 +0200

> Agreed -- please submit a patch.

Sure thing. It will take some time to get along with Docbook, indexing 
and everything.

	Mike

---

From: Mario Splivalo <[email-masked]>
Date: Wed, 01 Apr 2009 03:57:48 +0200

> Agreed -- please submit a patch.

Hope this is ok. How can I submit patch for 8.3 documentation?

	Mario
? func.sgml.patch
Index: doc/src/sgml/func.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/func.sgml,v
retrieving revision 1.473
diff -c -r1.473 func.sgml
*** doc/src/sgml/func.sgml	23 Mar 2009 21:00:38 -0000	1.473
--- doc/src/sgml/func.sgml	1 Apr 2009 01:48:14 -0000
***************
*** 9338,9343 ****
--- 9338,9380 ----
     for more discussion and examples of the use of these functions.
    </para>
  
+   <indexterm>
+     <primary>array_append</primary>
+   </indexterm>	
+   <indexterm>
+     <primary>array_cat</primary>
+   </indexterm>	
+   <indexterm>
+     <primary>array_ndims</primary>
+   </indexterm>	
+   <indexterm>
+     <primary>array_dims</primary>
+   </indexterm>	
+   <indexterm>
+     <primary>array_fill</primary>
+   </indexterm>	
+   <indexterm>
+     <primary>array_length</primary>
+   </indexterm>	
+   <indexterm>
+     <primary>array_lower</primary>
+   </indexterm>	
+   <indexterm>
+     <primary>array_prepend</primary>
+   </indexterm>	
+   <indexterm>
+     <primary>array_to_string</primary>
+   </indexterm>	
+  <indexterm>
+     <primary>array_upper</primary>
+   </indexterm>	
+   <indexterm>
+     <primary>string_to_array</primary>
+   </indexterm>	
+   <indexterm>
+     <primary>cardinality</primary>
+   </indexterm>	
+ 
      <table id="array-functions-table">
       <title>Array Functions</title>
       <tgroup cols="5">

---

From: Tom Lane <[email-masked]>
Date: Tue, 31 Mar 2009 23:33:29 -0400

> Hope this is ok. How can I submit patch for 8.3 documentation?

I think you just did.  Applied, thanks.

			regards, tom lane

PS: why'd you omit unnest()?

---

From: Mario Splivalo <[email-masked]>
Date: Wed, 01 Apr 2009 18:27:16 +0200

> I think you just did.  Applied, thanks.

I pulled the source from CVS HEAD branch, I see that is 8.4 
documentation (for instance, 'cardinality' function is nonexistant for 8.3).

> PS: why'd you omit unnest()?

I overlooked it, I guess. Sorry.

	Mike

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 9 Apr 2009 17:59:42 -0400 (EDT)

> I overlooked it, I guess. Sorry.

Did unnest() get added properly too?

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +

---

From: Tom Lane <[email-masked]>
Date: Thu, 09 Apr 2009 18:23:41 -0400

> Did unnest() get added properly too?

Yes, I included it in the patch.

			regards, tom lane